aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2017.03.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2017.03.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
new file mode 100644
index 00000000..b0e5f9f2
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
@@ -0,0 +1,24 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017 NXP
+
+DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES += "u-boot"
+DEPENDS_append = "dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCBRANCH = "imx_v2017.03_4.9.11_1.0.0_ga"
+SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
+SRCREV = "a2fea67d3eb3092f19f250d53a4a27fa1a0c815f"
+
+S = "${WORKDIR}/git"
+
+inherit fsl-u-boot-localversion
+
+LOCALVERSION ?= "-${SRCBRANCH}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6|mx7)"