aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2017.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2017.11.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2017.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.11.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.11.bb
new file mode 100644
index 00000000..5659e16c
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2017.11.bb
@@ -0,0 +1,21 @@
+require recipes-bsp/u-boot/u-boot.inc
+require u-boot-fslc-common_${PV}.inc
+
+DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
+order to provide support for some backported features and fixes, or because it \
+was submitted for revision and it takes some time to become part of a stable \
+version, or because it is not applicable for upstreaming."
+
+DEPENDS_append = " dtc-native"
+
+PROVIDES += "u-boot"
+
+# FIXME: Allow linking of 'tools' binaries with native libraries
+# used for generating the boot logo and other tools used
+# during the build process.
+EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
+ HOSTLDFLAGS="${BUILD_LDFLAGS}" \
+ HOSTSTRIP=true'
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"