aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mc-utils/mc-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mc-utils/mc-utils_git.bb')
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
index f34d4418..430d6cd8 100644
--- a/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -10,30 +10,36 @@ DEPENDS += "dtc-native"
inherit deploy
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1"
-SRCREV = "30c63101b15def4620f509641b97641c25fe19fe"
+SRCREV = "6aca560c630dc54afdef382c506f214b28f4985e"
S = "${WORKDIR}/git"
MC_CFG ?= ""
MC_CFG_ls1088a = "ls1088a"
MC_CFG_ls2088a = "ls2088a"
+MC_CFG_lx2160a = "lx2160a"
do_install () {
oe_runmake -C config
- install -d ${D}/boot/mc-utils/custom
+ install -d ${D}/boot/mc-utils
cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils
- cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
+ if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
+ install -d ${D}/boot/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
+ fi
}
do_deploy () {
- install -d ${DEPLOYDIR}/mc-utils/custom
+ install -d ${DEPLOYDIR}/mc-utils
cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils
- cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
-
+ if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
+ install -d ${DEPLOYDIR}/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
+ fi
}
addtask deploy after do_install
PACKAGES += "${PN}-image"
FILES_${PN}-image += "/boot"
-COMPATIBLE_MACHINE = "(ls1088a|ls2088a)"
+COMPATIBLE_MACHINE = "(qoriq-arm64)"