aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
deleted file mode 100644
index 27731004..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From cf67cfecc01538e32cd99e3ca00ff0e6145079ce Mon Sep 17 00:00:00 2001
-From: Yuqing Zhu <carol.zhu@nxp.com>
-Date: Thu, 27 Sep 2018 15:34:11 +0800
-Subject: [PATCH] imx-vpu-hantro: Fix ion.h header inclusion to be standard
-
-NXP "solution" was to manually copy the header to include/linux.
-Let's point the Makefile to the proper (mainline) location instead:
-https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
-
-Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
----
- Makefile_G1G2 | 3 +++
- Makefile_H1 | 3 +++
- decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
- h1_encoder/software/linux_reference/ewl/ewl_x280_common.c | 2 +-
- 4 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile_G1G2 b/Makefile_G1G2
-index caab40f..29866a4 100755
---- a/Makefile_G1G2
-+++ b/Makefile_G1G2
-@@ -13,6 +13,9 @@ INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
- #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
- INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
-
-+# ION header location
-+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
-+
- CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
- -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
- -DDEC_X170_OUTPUT_FORMAT=0 -DDEC_X170_TIMEOUT_LENGTH=-1 -DENABLE_HEVC_SUPPORT \
-diff --git a/Makefile_H1 b/Makefile_H1
-index 9ca1aa9..56b4332 100755
---- a/Makefile_H1
-+++ b/Makefile_H1
-@@ -20,6 +20,9 @@ ENV += -DUSE_ION
- ENV += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
- ENV += -I$(SDKTARGETSYSROOT)/usr/imx/include
-
-+# ION header location
-+ENV += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
-+
- LIBENCNAME = libcodec_enc
- LIBSENC = -L./ -lhantro_h1 -lpthread
-
-diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
-index 0899596..f2e1229 100755
---- a/decoder_sw/software/linux/dwl/dwl_linux.c
-+++ b/decoder_sw/software/linux/dwl/dwl_linux.c
-@@ -41,7 +41,7 @@
- #include "dwl.h"
- #include <linux/hantrodec.h>
- #ifdef USE_ION
--#include <linux/ion.h>
-+#include <ion.h>
- #include <linux/dma-buf.h>
- #include <linux/version.h>
- #ifdef ANDROID
-diff --git a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
-index 620c978..82b4836 100755
---- a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
-+++ b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
-@@ -49,7 +49,7 @@
-
- #include "linux/hx280enc.h"
- #ifdef USE_ION
--#include <linux/ion.h>
-+#include <ion.h>
- #include <linux/dma-buf.h>
- #include <linux/version.h>
- #ifdef ANDROID
---
-1.9.1
-