aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/elftosb/elftosb_10.12.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/elftosb/elftosb_10.12.01.bb')
-rw-r--r--recipes-bsp/elftosb/elftosb_10.12.01.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-bsp/elftosb/elftosb_10.12.01.bb b/recipes-bsp/elftosb/elftosb_10.12.01.bb
new file mode 100644
index 00000000..2cef1f6a
--- /dev/null
+++ b/recipes-bsp/elftosb/elftosb_10.12.01.bb
@@ -0,0 +1,22 @@
+# Copyright (C) 2011, 2012 Freescale
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Helper utility for freescale imx platforms"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029"
+SECTION = "bootloader"
+PR = "r4"
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \
+ file://cross-build.patch \
+ file://don-t-use-full-path-for-headers.patch"
+SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056"
+SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b"
+
+do_install() {
+ install -d ${D}${bindir}
+ install ${S}/bld/linux/elftosb ${D}${bindir}
+ install ${S}/bld/linux/keygen ${D}${bindir}
+ install ${S}/bld/linux/sbtool ${D}${bindir}
+}