aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb')
-rw-r--r--dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 00000000..34308e2d
--- /dev/null
+++ b/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
+SECTION = "asf"
+LICENSE = "GPLv2 & GPLv2+ & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.9.x"
+SRCREV = "9580a629d3aec3ab3c5e152c6693846b96787906"
+
+RDEPENDS_${PN} += "ipsec-tools"
+
+inherit module qoriq_build_64bit_kernel
+
+S = "${WORKDIR}/git/asfmodule"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+do_configure_prepend () {
+ find ${S} -name Makefile -exec \
+ sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
+}
+
+do_install(){
+ install -d ${D}/${libexecdir}
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/../scripts ${D}/${libexecdir}/
+ find ${D}/lib -depth -type d -exec rmdir --ignore-fail-on-non-empty {} \;
+}
+
+FILES_${PN} += "${libexecdir}"
+
+COMPATIBLE_MACHINE = "(qoriq)"