aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf6
-rw-r--r--dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend2
-rw-r--r--dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend2
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb12
4 files changed, 15 insertions, 7 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 1b71bead..93e5f97f 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -27,12 +27,18 @@ ${QORIQ_MIRROR} http://download.ossystems.com.br/bsp/freescale/source/ \n \
"
BBFILES_DYNAMIC += " \
+ aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bb \
+ aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bbappend \
+ \
browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bb \
browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bbappend \
\
filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bb \
filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bbappend \
\
+ ivi:${LAYERDIR}/dynamic-layers/ivi/*/*/*.bb \
+ ivi:${LAYERDIR}/dynamic-layers/ivi/*/*/*.bbappend \
+ \
networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \
networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \
\
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
new file mode 100644
index 00000000..1a896a20
--- /dev/null
+++ b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
@@ -0,0 +1,2 @@
+# don't install default weston.ini
+WESTON_INI_INSTALL_FILE = ""
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
new file mode 100644
index 00000000..d36fbd4d
--- /dev/null
+++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
@@ -0,0 +1,2 @@
+# install default weston.ini for IVI
+WESTON_INI_INSTALL_FILE = "${B}/ivi-shell/weston.ini"
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 9f32d94a..e9f354f0 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -102,6 +102,9 @@ PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d"
# Weston with OpenGL support
PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl"
+# Set to install a default weston.ini file
+WESTON_INI_INSTALL_FILE = "${B}/weston.ini"
+
do_install_append() {
# Weston doesn't need the .la files to load modules, so wipe them
rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
@@ -120,13 +123,8 @@ do_install_append() {
fi
# install default weston.ini
- if [ -n "${@bb.utils.filter('BBFILE_COLLECTIONS', 'aglprofilegraphical', d)}" ]; then
- if [ "${@bb.utils.filter('BBFILE_COLLECTIONS', 'ivi', d)}" ]; then
- WESTON_INI_SRCDIR=${B}/ivi-shell
- else
- WESTON_INI_SRCDIR=${B}
- fi
- install -D -m 0644 ${WESTON_INI_SRCDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
+ if [ "${WESTON_INI_INSTALL_FILE}" != "" ]; then
+ install -D -m 0644 ${WESTON_INI_INSTALL_FILE} ${D}${sysconfdir}/xdg/weston/weston.ini
fi
}