aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.14.1.bb2
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.20.4.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
index 52da410e..ddb305c1 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
@@ -25,7 +25,7 @@ do_deploy () {
install -d ${DEPLOYDIR}/mc_app
install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
# make a symlink to the latest binary
- for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
+ for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
done
}
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
index a687657c..3e14a26e 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
@@ -25,7 +25,7 @@ do_deploy () {
install -d ${DEPLOYDIR}/mc_app
install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
# make a symlink to the latest binary
- for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
+ for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
done
}