aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch27
-rw-r--r--recipes-dpaa2/dce/dce_git.bb19
2 files changed, 0 insertions, 46 deletions
diff --git a/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch b/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch
deleted file mode 100644
index de8ae0c8..00000000
--- a/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Subject: [PATCH] Makefile:Obey LDFLAGS in Makefile
-
-This avoids a "QA Issue: No GNU_HASH in the elf binary"
-
-Upstream-Status: Pending
-
-Signed-off-by:Chunrong Guo <chunrong.guo@nxp.com>
-
---- a/Makefileold 2017-04-19 15:32:36.512525035 +0800
-+++ b/Makefile 2017-04-19 15:34:29.560521121 +0800
-@@ -46,13 +46,13 @@
- all: basic_dce_test basic_dce_perf basic_dce_sanity
-
- basic_dce_test: tests/basic_dce_test.o libdce.a
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
-
- basic_dce_perf: tests/basic_dce_perf.o libdce.a
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
-
- basic_dce_sanity: tests/basic_dce_sanity.o libdce.a
-- $(CC) $(CFLAGS) $^ -o $@
-+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
-
- libdce.a: $(OBJS)
- $(AR) rcs $@ $(OBJS)
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb
deleted file mode 100644
index 0f0b283d..00000000
--- a/recipes-dpaa2/dce/dce_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Decompression Compression Engine Userspace Utils"
-SECTION = "dpaa2"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3bb80dec5c1b94d99a1422cbfd96192c"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/dce.git;nobranch=1 \
- file://Makefile-obey-LDFLAGS.patch \
-"
-SRCREV = "c31f81667f5cebb3e5331c50655473301672e4de"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
-
-do_install () {
- oe_runmake install DESTDIR=${D}
-}
-
-COMPATIBLE_MACHINE = "(ls2080a|ls2088a|ls1088a)"