aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch49
-rw-r--r--recipes-graphics/wayland/wayland-protocols_1.17.imx.bb4
2 files changed, 52 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch b/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch
new file mode 100644
index 00000000..16aabec8
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch
@@ -0,0 +1,49 @@
+From 50ea8fbdd1b768ccaa33dfee43b0f12245ef09b8 Mon Sep 17 00:00:00 2001
+From: Haihua Hu <jared.hu@nxp.com>
+Date: Wed, 5 Sep 2018 13:00:47 +0800
+Subject: [PATCH] linux-dmabuf: support passing buffer DTRC meta to compositor
+
+DTRC meta is untilized to pass offset to DTRC in drm dcss driver
+to enable video tile compress
+
+Signed-off-by: Haihua Hu <jared.hu@nxp.com>
+---
+ unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml | 22 ++++++++++++++++++++++
+ 1 file changed, 22 insertions(+)
+
+diff --git a/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml b/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml
+index 154afe2..9c955c7 100644
+--- a/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml
++++ b/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml
+@@ -343,6 +343,28 @@
+ <arg name="flags" type="uint" summary="see enum flags"/>
+ </request>
+
++ <request name="add_dtrc_meta">
++ <description summary="add dtrc meta in this dmabuf">
++ This request adds one dmabuf to the set in this
++ zwp_linux_buffer_params_v1.
++
++ The 64-bit unsigned value combined from modifier_hi and modifier_lo
++ is the dmabuf layout modifier. DRM AddFB2 ioctl calls this the
++ fb modifier, which is defined in drm_mode.h of Linux UAPI.
++ This is an opaque token. Drivers use this token to express tiling,
++ compression, etc. driver-specific modifications to the base format
++ defined by the DRM fourcc code.
++
++ This request raises the PLANE_IDX error if plane_idx is too large.
++ The error PLANE_SET is raised if attempting to set a plane that
++ was already set.
++ </description>
++ <arg name="rfc_chroma_offset" type="uint"
++ summary="high 32 bits of DTRC offset"/>
++ <arg name="rfc_luma_offset" type="uint"
++ summary="low 32 bits of DTRC offset"/>
++ </request>
++
+ </interface>
+
+ </protocol>
+--
+2.7.4
+
diff --git a/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb b/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb
index d070f03f..069bbea0 100644
--- a/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb
+++ b/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb
@@ -12,7 +12,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c7b12b6702da38ca028ace54aae3d484 \
ARCHIVE_NAME = "${BPN}-1.17"
SRC_URI = "https://wayland.freedesktop.org/releases/${ARCHIVE_NAME}.tar.xz \
file://0001-unstable-Add-alpha-compositing-protocol.patch \
- file://0002-unstable-Add-hdr10-metadata-protocol.patch"
+ file://0002-unstable-Add-hdr10-metadata-protocol.patch \
+ file://0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch \
+ "
SRC_URI[md5sum] = "55ddd5fdb02b73b9de9559aaec267315"
SRC_URI[sha256sum] = "df1319cf9705643aea9fd16f9056f4e5b2471bd10c0cc3713d4a4cdc23d6812f"
S = "${WORKDIR}/${ARCHIVE_NAME}"