aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/imx-base.inc4
-rw-r--r--recipes-graphics/wayland/wayland-protocols_1.13.imx.bb20
2 files changed, 24 insertions, 0 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 84a6acef..f0fc959a 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -226,6 +226,10 @@ PREFERRED_VERSION_weston_mx6 ?= "4.0.0.imx"
PREFERRED_VERSION_weston_mx7 ?= "4.0.0.imx"
PREFERRED_VERSION_weston_mx8 ?= "4.0.0.imx"
+PREFERRED_VERSION_wayland-protocols_mx6 ?= "1.13.imx"
+PREFERRED_VERSION_wayland-protocols_mx7 ?= "1.13.imx"
+PREFERRED_VERSION_wayland-protocols_mx8 ?= "1.13.imx"
+
# Use i.MX libdrm Version
PREFERRED_VERSION_libdrm_mx6 ?= "2.4.84.imx"
PREFERRED_VERSION_libdrm_mx7 ?= "2.4.84.imx"
diff --git a/recipes-graphics/wayland/wayland-protocols_1.13.imx.bb b/recipes-graphics/wayland/wayland-protocols_1.13.imx.bb
new file mode 100644
index 00000000..1ef1ee14
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-protocols_1.13.imx.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Collection of additional Wayland protocols"
+DESCRIPTION = "Wayland protocols that add functionality not \
+available in the Wayland core protocol. Such protocols either add \
+completely new functionality, or extend the functionality of some other \
+protocol either in Wayland core, or some other protocol in \
+wayland-protocols."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c7b12b6702da38ca028ace54aae3d484 \
+ file://stable/presentation-time/presentation-time.xml;endline=26;md5=4646cd7d9edc9fa55db941f2d3a7dc53"
+
+SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+ "
+SRC_URI[md5sum] = "29312149dafcd4a0e739ba94995a574d"
+SRC_URI[sha256sum] = "0758bc8008d5332f431b2a84fea7de64d971ce270ed208206a098ff2ebc68f38"
+
+inherit allarch autotools pkgconfig
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${datadir}/pkgconfig/wayland-protocols.pc"