aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/odp/odp.inc7
-rw-r--r--recipes-extended/odp/odp_git.bb6
2 files changed, 6 insertions, 7 deletions
diff --git a/recipes-extended/odp/odp.inc b/recipes-extended/odp/odp.inc
index 421deff2..5d8d7891 100644
--- a/recipes-extended/odp/odp.inc
+++ b/recipes-extended/odp/odp.inc
@@ -4,7 +4,7 @@ DESCRIPTION = "OpenDataPlane (ODP) provides a data plane application programming
HOMEPAGE = "http://www.opendataplane.org"
SECTION = "console/network"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=472053b942339f200d9e1d2dcb947e9d"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ca6103dc75397fb6bec596187d6b7829"
FILESEXTRAPATHS_prepend := "${THISDIR}/odp:"
@@ -16,9 +16,10 @@ git://github.com/qoriq-open-source/flib.git;nobranch=1;name=rta;destsuffix=git/p
SRC_URI += "file://0001-Fix-this-build-error.patch"
-SRCREV = "fdb26cb5c751afadf2299da2a1376e6ca0e61cc7"
+SRCREV = "bef6398a09db4a6b909aa0c6accc7c15621ce5ef"
+
SRCREV_qbman = "097595befc2bb60b733027e94ad2ed16a0e9cae0"
-SRCREV_rta = "2c9b9dc22699f7c00f24a2134c42901932a6a0b9"
+SRCREV_rta = "bbab28b03ae21c52ce913f8b052acf53bd24ff5d"
S = "${WORKDIR}/git"
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
index b7c7deb6..b9d45581 100644
--- a/recipes-extended/odp/odp_git.bb
+++ b/recipes-extended/odp/odp_git.bb
@@ -12,8 +12,6 @@ ODP_SOC ?= ""
ODP_SOC_ls1043ardb = "LS1043"
ODP_SOC_ls1046ardb = "LS1046"
ODP_PLATFORM ?= "linux-dpaa2"
-ODP_PLATFORM_ls1043ardb = "linux-dpaa1"
-ODP_PLATFORM_ls1046ardb = "linux-dpaa1"
ODP_BUILD_TYPE ?= "ls2088"
ODP_BUILD_TYPE_ls1043ardb = "ls1043"
ODP_BUILD_TYPE_ls1046ardb = "ls1046"
@@ -21,8 +19,6 @@ ODP_BUILD_TYPE_ls2080ardb = "ls2080"
ODP_BUILD_TYPE_ls1088ardb = "ls1088"
EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
- --with-sdk-install-path=${STAGING_DIR_TARGET} \
- --enable-build-type=${ODP_BUILD_TYPE} \
--enable-test-vald \
--enable-test-perf \
--enable-test-cpp \
@@ -32,6 +28,8 @@ EXTRA_OEMAKE = "CROSS_COMPILE="${TARGET_PREFIX}" \
SYSROOT="${STAGING_DIR_TARGET}" \
"
+CFLAGS += "-Wno-format-truncation -Wno-maybe-uninitialized -Wno-implicit-fallthrough"
+
PACKAGECONFIG[perf] = "--enable-test-perf,,,"
do_configure_prepend () {