aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
index 79ef450c..13d4c08a 100644
--- a/recipes-extended/skmm-ep/skmm-ep_git.bb
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -15,18 +15,17 @@ SRCREV = "27156a6621c8f6d7f98210b1ca5cd97bde926875"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'MACHINE=${MACHINE}'
+EXTRA_OEMAKE = 'ARCH=${TARGET_ARCH} MACHINE=${MACHINE}'
export LIBEDIT_CFLAGS = "`pkg-config --cflags libedit`"
export LIBEDIT_LDFLAGS = "`pkg-config --libs --static libedit`"
do_compile () {
- export ARCH=${TARGET_ARCH}
oe_runmake
}
do_install () {
- oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D}
+ oe_runmake install DESTDIR=${D}
}
COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"