aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ls2-phy/ls2-phy_git.bb14
1 files changed, 6 insertions, 8 deletions
diff --git a/recipes-bsp/ls2-phy/ls2-phy_git.bb b/recipes-bsp/ls2-phy/ls2-phy_git.bb
index d21147f2..9f2d79fe 100644
--- a/recipes-bsp/ls2-phy/ls2-phy_git.bb
+++ b/recipes-bsp/ls2-phy/ls2-phy_git.bb
@@ -1,24 +1,22 @@
SUMMARY = "Firmwares and Standalone Applications"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
inherit deploy
-SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-phy.git;branch=sdk-v2.0.x"
-SRCREV = "554f2648c6a4c6f974827ab326e8c1908dead6f1"
+SRC_URI = "git://github.com/qoriq-open-source/firmware-cortina.git;nobranch=1"
+SRCREV = "6036a20ddbf796ac494da172f2588e5de4d833fc"
S = "${WORKDIR}/git"
do_install () {
install -d ${D}/boot
- cp -fr ${S}/AQR405 ${D}/boot
- cp -fr ${S}/CS4340 ${D}/boot
+ cp -fr ${S}/* ${D}/boot
}
do_deploy () {
install -d ${DEPLOYDIR}/ls2-phy
- cp -fr ${S}/AQR405 ${DEPLOYDIR}/ls2-phy
- cp -fr ${S}/CS4340 ${DEPLOYDIR}/ls2-phy
+ cp -fr ${S}/* ${DEPLOYDIR}/ls2-phy
}
addtask deploy before do_build after do_install