aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch51
-rw-r--r--recipes-extended/dpdk/dpdk_17.11.bb7
2 files changed, 55 insertions, 3 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch b/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch
new file mode 100644
index 00000000..51987b53
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch
@@ -0,0 +1,51 @@
+From 7409d0b89f80a72d91e02dc9ec688a01723c3c66 Mon Sep 17 00:00:00 2001
+From: Chunrong Guo <chunrong.guo@nxp.com>
+Date: Wed, 4 Jul 2018 17:12:39 +0800
+Subject: [PATCH] fix gcc-8 build error
+
+Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
+---
+ examples/ipsec-secgw/parser.c | 6 ++----
+ mk/toolchain/gcc/rte.vars.mk | 2 +-
+ 2 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/examples/ipsec-secgw/parser.c b/examples/ipsec-secgw/parser.c
+index 9d0ea46..b2b30e4 100644
+--- a/examples/ipsec-secgw/parser.c
++++ b/examples/ipsec-secgw/parser.c
+@@ -544,8 +544,7 @@ parse_cfg_file(const char *cfg_filename)
+ goto error_exit;
+ }
+
+- strncpy(str + strlen(str), oneline,
+- strlen(oneline));
++ strcpy(str + strlen(str), oneline);
+
+ continue;
+ }
+@@ -557,8 +556,7 @@ parse_cfg_file(const char *cfg_filename)
+ cfg_filename, line_num);
+ goto error_exit;
+ }
+- strncpy(str + strlen(str), oneline,
+- strlen(oneline));
++ strcpy(str + strlen(str), oneline);
+
+ str[strlen(str)] = '\n';
+ if (cmdline_parse(cl, str) < 0) {
+diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
+index 3b907e2..cc63da8 100644
+--- a/mk/toolchain/gcc/rte.vars.mk
++++ b/mk/toolchain/gcc/rte.vars.mk
+@@ -75,7 +75,7 @@ WERROR_FLAGS := -W -Wall -Wstrict-prototypes -Wmissing-prototypes
+ WERROR_FLAGS += -Wmissing-declarations -Wold-style-definition -Wpointer-arith
+ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
+ WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
+-WERROR_FLAGS += -Wundef -Wwrite-strings
++WERROR_FLAGS += -Wundef -Wwrite-strings -Wno-cast-function-type
+
+ ifeq ($(RTE_DEVEL_BUILD),y)
+ WERROR_FLAGS += -Werror
+--
+2.7.4
+
diff --git a/recipes-extended/dpdk/dpdk_17.11.bb b/recipes-extended/dpdk/dpdk_17.11.bb
index 43a18599..2010e0c2 100644
--- a/recipes-extended/dpdk/dpdk_17.11.bb
+++ b/recipes-extended/dpdk/dpdk_17.11.bb
@@ -11,8 +11,9 @@ inherit module
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \
file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
+ file://0001-fix-gcc-8-build-error.patch \
"
-SRCREV = "11d461d88390eb77bbf695eeddaad8e6f6cc25ce"
+SRCREV = "9448fe7ff3cf1367dbc92b05a9ae386b21ff7ad2"
S = "${WORKDIR}/git"
@@ -40,12 +41,12 @@ do_install() {
oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
# Build and install the DPDK examples
- for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do
+ for APP in examples/l2fwd examples/l3fwd examples/l2fwd-qdma examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do
temp=`basename ${APP}`
if [ ${temp} = "ipsec-secgw" ] || [ ${temp} = "l2fwd-crypto" ]; then
oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
else
- oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP}
+ oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" EXTRA_CFLAGS="--sysroot=${STAGING_DIR_HOST} -I${STAGING_INCDIR}" -C ${APP}
fi
[ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example