aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch)37
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb33
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb35
3 files changed, 52 insertions, 53 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
index 951ead98..e7b23f7e 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
@@ -13,23 +13,10 @@ Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
2 files changed, 3 insertions(+), 1 deletion(-)
-diff --git a/Makefile b/Makefile
-index b74e23a..a5ce22b 100755
---- a/Makefile
-+++ b/Makefile
-@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOURCE_ROOT)/source/inc -I$(SOURCE_ROOT)/so
- INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
- #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
- INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
-+# ION header location
-+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
-
- CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
- -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
-diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
-index 8183660..ed37d86 100644
---- a/decoder_sw/software/linux/dwl/dwl_linux.c
-+++ b/decoder_sw/software/linux/dwl/dwl_linux.c
+Index: imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
+===================================================================
+--- imx-vpu-hantro-1.7.0.orig/decoder_sw/software/linux/dwl/dwl_linux.c
++++ imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
@@ -41,7 +41,7 @@
#include "dwl.h"
#include <linux/hantrodec.h>
@@ -39,6 +26,16 @@ index 8183660..ed37d86 100644
#ifdef ANDROID
#include <linux/mxc_ion.h>
#endif
---
-2.18.0
-
+Index: imx-vpu-hantro-1.7.0/Makefile_G1G2
+===================================================================
+--- imx-vpu-hantro-1.7.0.orig/Makefile_G1G2
++++ imx-vpu-hantro-1.7.0/Makefile_G1G2
+@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOU
+ INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
+ #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
+ INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
++# ION header location
++INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
+
+ CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
+ -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
deleted file mode 100644
index 609d6928..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 2017 NXP
-
-DESCRIPTION = "i.MX Hantro VPU library"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671"
-
-DEPENDS = "virtual/kernel"
-
-PROVIDES = "virtual/imxvpu"
-
-SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
- file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
-"
-
-SRC_URI[md5sum] = "09ec833586afb5f194ce0202da925ed6"
-SRC_URI[sha256sum] = "cbc648e41f005aad209f74c9e5dd346138dca12efeb7b27e471de7474c4da302"
-
-inherit fsl-eula-unpack
-
-PARALLEL_MAKE="-j 1"
-
-do_compile () {
- oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" all
-}
-
-do_install () {
- oe_runmake DEST_DIR="${D}" install
-}
-
-FILES_${PN} += "/unit_tests"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(mx8mq)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb
new file mode 100644
index 00000000..da2ac513
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb
@@ -0,0 +1,35 @@
+# Copyright 2017-2018 NXP
+
+DESCRIPTION = "i.MX Hantro VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28"
+
+DEPENDS = "virtual/kernel"
+
+PROVIDES = "virtual/imxvpu"
+
+SRC_URI = " \
+ ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
+ file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
+"
+SRC_URI[md5sum] = "9a8ade25333e6ac3f7c345b71f3477a6"
+SRC_URI[sha256sum] = "a3bbf2d8ac00ecae6d48b05cb94d9bdf68085d5bfc54eb176e3bf59670a87ad1"
+
+inherit fsl-eula-unpack
+
+PARALLEL_MAKE="-j 1"
+
+PLATFORM_mx8mq = "IMX8MQ"
+
+do_compile () {
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" PLATFORM="${PLATFORM}" all
+}
+
+do_install () {
+ oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
+}
+
+FILES_${PN} += "/unit_tests"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx8mq)"