aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/image_types_fsl.bbclass68
-rw-r--r--recipes-bsp/barebox/barebox.inc63
-rw-r--r--recipes-bsp/barebox/barebox_2015.10.0.bb9
-rw-r--r--recipes-bsp/elftosb/elftosb_10.12.01.bb22
-rw-r--r--recipes-bsp/elftosb/files/cross-build.patch50
-rw-r--r--recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch42
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch46
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch28
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch30
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb79
-rw-r--r--recipes-core/packagegroup/nativesdk-packagegroup-sdk-host.bbappend1
-rw-r--r--wic/imx-barebox.wks19
12 files changed, 2 insertions, 455 deletions
diff --git a/classes/image_types_fsl.bbclass b/classes/image_types_fsl.bbclass
index e7627200..e49bb1af 100644
--- a/classes/image_types_fsl.bbclass
+++ b/classes/image_types_fsl.bbclass
@@ -11,20 +11,6 @@ UBOOT_SUFFIX_SDCARD ?= "${UBOOT_SUFFIX}"
#
MXSBOOT_NAND_ARGS ?= ""
-# IMX Bootlets barebox bootstream
-do_image_barebox-mxsboot-sdcard[depends] += "elftosb-native:do_populate_sysroot \
- u-boot-mxsboot-native:do_populate_sysroot \
- imx-bootlets:do_deploy \
- barebox:do_deploy"
-IMAGE_CMD_barebox-mxsboot-sdcard () {
- barebox_bd_file=imx-bootlets-barebox_ivt.bd-${MACHINE}
-
- # Ensure the files are generated
- (cd ${DEPLOY_DIR_IMAGE}; rm -f ${IMAGE_NAME}.barebox.sb ${IMAGE_NAME}.barebox-mxsboot-sdcard; \
- elftosb -f mx28 -z -c $barebox_bd_file -o ${IMAGE_NAME}.barebox.sb; \
- mxsboot sd ${IMAGE_NAME}.barebox.sb ${IMAGE_NAME}.barebox-mxsboot-sdcard)
-}
-
# U-Boot mxsboot generation to SD-Card
UBOOT_SUFFIX_SDCARD_mxs ?= "mxsboot-sdcard"
do_image_uboot_mxsboot_sdcard[depends] += "u-boot-mxsboot-native:do_populate_sysroot \
@@ -44,9 +30,6 @@ BOOTDD_VOLUME_ID ?= "Boot ${MACHINE}"
# Boot partition size [in KiB]
BOOT_SPACE ?= "8192"
-# Barebox environment size [in KiB]
-BAREBOX_ENV_SPACE ?= "512"
-
# Set alignment to 4MB [in KiB]
IMAGE_ROOTFS_ALIGNMENT = "4096"
@@ -125,7 +108,7 @@ _generate_boot_image() {
#
# External variables needed:
# ${SDCARD_ROOTFS} - the rootfs image to incorporate
-# ${IMAGE_BOOTLOADER} - bootloader to use {u-boot, barebox}
+# ${IMAGE_BOOTLOADER} - bootloader to use
#
# The disk layout used is:
#
@@ -153,10 +136,6 @@ generate_imx_sdcard () {
# Burn bootloader
case "${IMAGE_BOOTLOADER}" in
- imx-bootlets)
- bberror "The imx-bootlets is not supported for i.MX based machines"
- exit 1
- ;;
u-boot)
if [ -n "${SPL_BINARY}" ]; then
dd if=${DEPLOY_DIR_IMAGE}/${SPL_BINARY} of=${SDCARD} conv=notrunc seek=2 bs=512
@@ -165,12 +144,6 @@ generate_imx_sdcard () {
dd if=${DEPLOY_DIR_IMAGE}/u-boot-${MACHINE}.${UBOOT_SUFFIX_SDCARD} of=${SDCARD} conv=notrunc seek=2 bs=512
fi
;;
- barebox)
- dd if=${DEPLOY_DIR_IMAGE}/barebox-${MACHINE}.bin of=${SDCARD} conv=notrunc seek=1 skip=1 bs=512
- dd if=${DEPLOY_DIR_IMAGE}/bareboxenv-${MACHINE}.bin of=${SDCARD} conv=notrunc seek=1 bs=512k
- ;;
- "")
- ;;
*)
bberror "Unknown IMAGE_BOOTLOADER value"
exit 1
@@ -190,40 +163,13 @@ generate_imx_sdcard () {
#
# External variables needed:
# ${SDCARD_ROOTFS} - the rootfs image to incorporate
-# ${IMAGE_BOOTLOADER} - bootloader to use {imx-bootlets, u-boot}
+# ${IMAGE_BOOTLOADER} - bootloader to use
#
generate_mxs_sdcard () {
# Create partition table
parted -s ${SDCARD} mklabel msdos
case "${IMAGE_BOOTLOADER}" in
- imx-bootlets)
- # The disk layout used is:
- #
- # 0 -> 1024 - Unused (not partitioned)
- # 1024 -> BOOT_SPACE - kernel and other data (bootstream)
- # BOOT_SPACE -> SDIMG_SIZE - rootfs
- #
- # Default Free space = 1.3x
- # Use IMAGE_OVERHEAD_FACTOR to add more space
- # <--------->
- # 1024 8MiB SDIMG_ROOTFS 4MiB
- # <-------> <----------> <----------------------> <------------------------------>
- # --------------------- ------------------------ -------------------------------
- # | Unused | BOOT_SPACE | ROOTFS_SIZE | IMAGE_ROOTFS_ALIGNMENT |
- # --------------------- ------------------------ -------------------------------
- # ^ ^ ^ ^ ^
- # | | | | |
- # 0 1024 1024 + 8MiB 1024 + 8Mib + SDIMG_ROOTFS 1024 + 8MiB + SDIMG_ROOTFS + 4MiB
- parted -s ${SDCARD} unit KiB mkpart primary 1024 $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED})
- parted -s ${SDCARD} unit KiB mkpart primary $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED}) $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED} \+ $ROOTFS_SIZE)
-
- # Empty 4 blocks from boot partition
- dd if=/dev/zero of=${SDCARD} conv=notrunc seek=2048 count=4
-
- # Write the bootstream in (2048 + 4) blocks
- dd if=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.linux.sb of=${SDCARD} conv=notrunc seek=2052
- ;;
u-boot)
# The disk layout used is:
#
@@ -259,15 +205,6 @@ generate_mxs_sdcard () {
dd if=${WORKDIR}/boot.img of=${SDCARD} conv=notrunc seek=2 bs=$(expr 1024 \* 1024)
;;
- barebox)
- # BAREBOX_ENV_SPACE is taken on BOOT_SPACE_ALIGNED but it doesn't really matter as long as the rootfs is aligned
- parted -s ${SDCARD} unit KiB mkpart primary 1024 $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED} - ${BAREBOX_ENV_SPACE})
- parted -s ${SDCARD} unit KiB mkpart primary $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED} - ${BAREBOX_ENV_SPACE}) $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED})
- parted -s ${SDCARD} unit KiB mkpart primary $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED}) $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED} \+ $ROOTFS_SIZE)
-
- dd if=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.barebox-mxsboot-sdcard of=${SDCARD} conv=notrunc seek=1 bs=$(expr 1024 \* 1024)
- dd if=${DEPLOY_DIR_IMAGE}/bareboxenv-${MACHINE}.bin of=${SDCARD} conv=notrunc seek=$(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${BOOT_SPACE_ALIGNED} - ${BAREBOX_ENV_SPACE}) bs=1024
- ;;
*)
bberror "Unknown IMAGE_BOOTLOADER value"
exit 1
@@ -310,7 +247,6 @@ IMAGE_TYPEDEP_sdcard_append = " ${@d.getVar('SDCARD_ROOTFS', 1).split('.')[-1]}"
# image stream built before the sdcard generation
IMAGE_TYPEDEP_sdcard_append = " \
${@bb.utils.contains('IMAGE_FSTYPES', 'uboot-mxsboot-sdcard', 'uboot-mxsboot-sdcard', '', d)} \
- ${@bb.utils.contains('IMAGE_FSTYPES', 'barebox-mxsboot-sdcard', 'barebox-mxsboot-sdcard', '', d)} \
"
# In case we are building for i.MX23 or i.MX28 we need to have the
diff --git a/recipes-bsp/barebox/barebox.inc b/recipes-bsp/barebox/barebox.inc
deleted file mode 100644
index 20e5a4ff..00000000
--- a/recipes-bsp/barebox/barebox.inc
+++ /dev/null
@@ -1,63 +0,0 @@
-DESCRIPTION = "Barebox - a bootloader that inherits the best of U-Boot and the Linux kernel"
-HOMEPAGE = "http://www.barebox.org/"
-SECTION = "bootloader"
-PROVIDES = "virtual/bootloader"
-PRIORITY = "optional"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=057bf9e50e1ca857d0eb97bfe4ba8e5d"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit kernel-arch
-
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-
-BAREBOX_BINARY ?= "barebox.bin"
-BAREBOX_IMAGE ?= "barebox-${MACHINE}-${PV}-${PR}.bin"
-BAREBOXENV_BIN ?= "bareboxenv-${MACHINE}-${PV}-${PR}.bin"
-BAREBOX_SYMLINK ?= "barebox-${MACHINE}.bin"
-BAREBOXENV_SYMLINK ?= "bareboxenv-${MACHINE}.bin"
-
-INSANE_SKIP_${PN} = "True"
-
-do_pre_configure() {
- cp ${WORKDIR}/defconfig ${S}/.config
- oe_runmake oldconfig
-}
-addtask pre_configure before do_configure after do_patch
-
-do_compile () {
- if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' Makefile
- fi
- unset LDFLAGS
- unset CFLAGS
- unset CPPFLAGS
- oe_runmake all
-}
-
-do_deploy () {
- install -d ${DEPLOY_DIR_IMAGE}
- install ${S}/${BAREBOX_BINARY} ${DEPLOY_DIR_IMAGE}/${BAREBOX_IMAGE}
-
- cd ${DEPLOY_DIR_IMAGE}
- rm -f ${BAREBOX_SYMLINK}
- ln -sf ${BAREBOX_IMAGE} ${BAREBOX_SYMLINK}
-
- install -d ${STAGING_BINDIR_NATIVE}
- cd ${S}
- install -m 755 scripts/mkimage ${STAGING_BINDIR_NATIVE}/
- install -m 755 scripts/bareboxenv ${STAGING_BINDIR_NATIVE}/
-}
-
-do_deploy[dirs] = "${S}"
-addtask deploy before do_build after do_compile
-
-do_env_deploy() {
- install ${S}/defaultenv/barebox_default_env ${DEPLOY_DIR_IMAGE}/${BAREBOXENV_BIN}
-
- cd ${DEPLOY_DIR_IMAGE}
- rm -f ${BAREBOXENV_SYMLINK}
- ln -sf ${BAREBOXENV_BIN} ${BAREBOXENV_SYMLINK}
-}
-addtask env_deploy before do_build after do_deploy
diff --git a/recipes-bsp/barebox/barebox_2015.10.0.bb b/recipes-bsp/barebox/barebox_2015.10.0.bb
deleted file mode 100644
index 3efc290e..00000000
--- a/recipes-bsp/barebox/barebox_2015.10.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require recipes-bsp/barebox/barebox.inc
-
-SRC_URI = "http://barebox.org/download/${PN}-${PV}.tar.bz2 \
- file://defconfig"
-
-SRC_URI[md5sum] = "50b787db3f91bebd5ed646e80a05caab"
-SRC_URI[sha256sum] = "8353042fe27a30a01a00fe1e1f4a34f292a291027b9637d3ea8f305387407880"
-
-COMPATIBLE_MACHINE = "Invalid!"
diff --git a/recipes-bsp/elftosb/elftosb_10.12.01.bb b/recipes-bsp/elftosb/elftosb_10.12.01.bb
deleted file mode 100644
index 2cef1f6a..00000000
--- a/recipes-bsp/elftosb/elftosb_10.12.01.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright (C) 2011, 2012 Freescale
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-DESCRIPTION = "Helper utility for freescale imx platforms"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029"
-SECTION = "bootloader"
-PR = "r4"
-BBCLASSEXTEND = "native nativesdk"
-
-SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \
- file://cross-build.patch \
- file://don-t-use-full-path-for-headers.patch"
-SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056"
-SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b"
-
-do_install() {
- install -d ${D}${bindir}
- install ${S}/bld/linux/elftosb ${D}${bindir}
- install ${S}/bld/linux/keygen ${D}${bindir}
- install ${S}/bld/linux/sbtool ${D}${bindir}
-}
diff --git a/recipes-bsp/elftosb/files/cross-build.patch b/recipes-bsp/elftosb/files/cross-build.patch
deleted file mode 100644
index 8cffa03e..00000000
--- a/recipes-bsp/elftosb/files/cross-build.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/makefile.rules.orig 2012-05-09 21:03:28.000000000 +0200
-+++ b/makefile.rules 2012-05-09 21:03:56.000000000 +0200
-@@ -9,6 +9,8 @@
- # SRC_DIR needs to be passed in. It is assumed that make is running in
- # the build directory.
-
-+CC ?= gcc
-+
- #*******************************************************************************
- # Environment
-
-@@ -101,7 +103,7 @@
- keygen.o
-
-
--LIBS = -lstdc++
-+LIBS ?= -lstdc++ -lm
-
-
- ifeq ("${UNAMES}", "Linux")
-@@ -137,13 +139,13 @@
- ${EXEC_FILE_ELFTOSB2} ${EXEC_FILE_SBTOOL} ${EXEC_FILE_KEYGEN}
-
- elftosb: ${OBJ_FILES_ELFTOSB2}
-- gcc ${OBJ_FILES_ELFTOSB2} ${LIBS} -o ${EXEC_FILE_ELFTOSB2}
-+ ${CC} ${OBJ_FILES_ELFTOSB2} ${LIBS} -o ${EXEC_FILE_ELFTOSB2}
-
- sbtool: ${OBJ_FILES_SBTOOL}
-- gcc ${OBJ_FILES_SBTOOL} ${LIBS} -o ${EXEC_FILE_SBTOOL}
-+ ${CC} ${OBJ_FILES_SBTOOL} ${LIBS} -o ${EXEC_FILE_SBTOOL}
-
- keygen: ${OBJ_FILES_KEYGEN}
-- gcc ${OBJ_FILES_KEYGEN} ${LIBS} -o ${EXEC_FILE_KEYGEN}
-+ ${CC} ${OBJ_FILES_KEYGEN} ${LIBS} -o ${EXEC_FILE_KEYGEN}
-
-
- #ifeq ("${UNAMES}", "Linux")
-@@ -153,10 +155,10 @@
- .SUFFIXES : .c .cpp
-
- .c.o :
-- gcc ${CFLAGS} -c $<
-+ ${CC} ${CFLAGS} -c $<
-
- .cpp.o :
-- gcc ${CFLAGS} -c $<
-+ ${CC} ${CFLAGS} -c $<
-
- #endif
-
diff --git a/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch b/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch
deleted file mode 100644
index 8996ffbb..00000000
--- a/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-elftosb: don't use full path for headers
-
-This fixes the building on new host distributions where header might
-move due multilib support and other possible changes in future.
-
-Upstream-Status: Pending
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- common/stdafx.h | 2 +-
- stdafx.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/common/stdafx.h b/common/stdafx.h
-index e6bf9dd..fb3c2d7 100644
---- a/common/stdafx.h
-+++ b/common/stdafx.h
-@@ -27,7 +27,7 @@
- // For Linux systems only, types.h only defines the signed
- // integer types. This is not professional code.
- // Update: They are defined in the header files in the more recent version of redhat enterprise gcc.
--#include "/usr/include/sys/types.h"
-+#include <sys/types.h>
- #include <stdint.h>
- //typedef unsigned long uint32_t;
- //typedef unsigned short uint16_t;
-diff --git a/stdafx.h b/stdafx.h
-index ce80458..6ff2f44 100644
---- a/stdafx.h
-+++ b/stdafx.h
-@@ -27,7 +27,7 @@
- // For Linux systems only, types.h only defines the signed
- // integer types. This is not professional code.
- // Update: They are defined in the header files in the more recent version of redhat enterprise gcc.
--#include "/usr/include/sys/types.h"
-+#include <sys/types.h>
- //typedef unsigned long uint32_t;
- //typedef unsigned short uint16_t;
- //typedef unsigned char uint8_t;
---
-1.7.2.5
-
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch b/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch
deleted file mode 100644
index 1deca1cb..00000000
--- a/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-imx-bootlets: Add command script for barebox
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
-
-diff --git a/barebox_ivt.bd b/barebox_ivt.bd
-new file mode 100644
-index 0000000..79cbccf
---- /dev/null
-+++ b/barebox_ivt.bd
-@@ -0,0 +1,34 @@
-+// STMP378x ROM command script to load and run barebox
-+
-+sources {
-+ power_prep="imx-bootlets-power_prep-@MACHINE@";
-+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
-+ barebox="barebox-@MACHINE@.bin";
-+}
-+
-+section (0) {
-+
-+ //----------------------------------------------------------
-+ // Power Supply initialization
-+ //----------------------------------------------------------
-+
-+ load power_prep;
-+ load ivt (entry = power_prep:_start) > 0x8000;
-+ hab call 0x8000;
-+
-+ //----------------------------------------------------------
-+ // SDRAM initialization
-+ //----------------------------------------------------------
-+
-+ load sdram_prep;
-+ load ivt (entry = sdram_prep:_start) > 0x8000;
-+ hab call 0x8000;
-+ //----------------------------------------------------------
-+ // Load and call barebox - ELF ARM image
-+ //----------------------------------------------------------
-+
-+ load barebox;
-+ load ivt (entry = barebox:start) > 0x8000;
-+ hab call 0x8000;
-+
-+}
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
deleted file mode 100644
index d54add12..00000000
--- a/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-imx-bootlets: Fix paths for used during boot stream generation
-
-This will be run during image generation thus this won't use a
-complete path to allow for relocation.
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
-diff --git a/linux.bd b/linux.bd
-index 516f4f2..366ac22 100644
---- a/linux.bd
-+++ b/linux.bd
-@@ -4,10 +4,10 @@
- flags = 0x01;
- }
- sources {
-- power_prep="./power_prep/power_prep";
-- sdram_prep="./boot_prep/boot_prep";
-- linux_prep="./linux_prep/output-target/linux_prep";
-- zImage = "./zImage";
-+ power_prep="imx-bootlets-power_prep-@MACHINE@";
-+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
-+ linux_prep="imx-bootlets-linux_prep-@MACHINE@";
-+ zImage="zImage-@MACHINE@.bin@DTB@";
- }
-
- section (0) {
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch
deleted file mode 100644
index 4fb4c519..00000000
--- a/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-imx-bootlets: Fix cmdlines for Linux boot
-
-This adapt the cmdlines for the partitioning layout used on the
-generated SD cards.
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
-diff --git a/linux_prep/cmdlines/iMX28_EVK.txt b/linux_prep/cmdlines/iMX28_EVK.txt
-index 6bc36b9..6cf89a0 100644
---- a/linux_prep/cmdlines/iMX28_EVK.txt
-+++ b/linux_prep/cmdlines/iMX28_EVK.txt
-@@ -1 +1 @@
--console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
-diff --git a/linux_prep/cmdlines/stmp378x_dev.txt b/linux_prep/cmdlines/stmp378x_dev.txt
-index 9a717eb..fdb7390 100644
---- a/linux_prep/cmdlines/stmp378x_dev.txt
-+++ b/linux_prep/cmdlines/stmp378x_dev.txt
-@@ -1,6 +1,3 @@
--console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms430 no_console_suspend
--console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms350
--console=ttyAM0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
--
--
--
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms430 no_console_suspend
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms350
-+console=ttyAMA0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
deleted file mode 100644
index 6084f169..00000000
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ /dev/null
@@ -1,79 +0,0 @@
-DESCRIPTION = "i.MXS boot streams"
-LICENSE = "GPL-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-PR = "r5"
-
-SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
- file://linux-fix-paths.patch \
- file://linux_prep-fix-cmdlines.patch \
- file://add-command-script-for-barebox.patch"
-
-SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4"
-SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883dfab1ffc"
-
-S = "${WORKDIR}/imx-bootlets-src-${PV}"
-
-inherit deploy
-
-# Disable parallel building or it may fail to build.
-PARALLEL_MAKE = ""
-
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-
-# Ensure machine defines the IMXBOOTLETS_MACHINE
-python () {
- if not d.getVar("IMXBOOTLETS_MACHINE", True):
- PN = d.getVar("PN", True)
- FILE = os.path.basename(d.getVar("FILE", True))
- bb.debug(1, "To build %s, see %s for instructions on \
- setting up your machine config" % (PN, FILE))
- raise bb.parse.SkipPackage("because IMXBOOTLETS_MACHINE is not set")
-}
-
-do_configure () {
- # Use machine specific binaries
- sed 's,@MACHINE@,${MACHINE},g;s,@DTB@,-dtb,g' < linux.bd > linux.bd-dtb
- sed -i 's,@MACHINE@,${MACHINE},g;s,@DTB@,,g' linux.bd
- sed -i 's,@MACHINE@,${MACHINE},g' barebox_ivt.bd
-}
-
-do_compile () {
- oe_runmake BOARD=${IMXBOOTLETS_MACHINE} linux_prep \
- boot_prep \
- power_prep \
- 'CC=${TARGET_PREFIX}gcc --sysroot="${STAGING_DIR_TARGET}"' \
- 'LD=${TARGET_PREFIX}ld --sysroot="${STAGING_DIR_TARGET}"'
-}
-
-do_install () {
- install -d ${D}/boot/
- install -m 644 boot_prep/boot_prep power_prep/power_prep \
- linux_prep/output-target/linux_prep \
- linux.bd linux.bd-dtb \
- barebox_ivt.bd \
- ${D}/boot
-}
-
-FILES_${PN} = "/boot"
-
-do_deploy () {
- install -d ${DEPLOYDIR}
-
- for f in boot_prep/boot_prep \
- power_prep/power_prep \
- linux_prep/output-target/linux_prep \
- barebox_ivt.bd \
- linux.bd linux.bd-dtb; do
- full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
- symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
-
- install -m 644 ${S}/$f ${DEPLOYDIR}/$full_name
- (cd ${DEPLOYDIR} ; rm -f $symlink_name ; ln -sf $full_name $symlink_name)
- done
-}
-
-addtask deploy before do_build after do_compile
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(mxs)"
diff --git a/recipes-core/packagegroup/nativesdk-packagegroup-sdk-host.bbappend b/recipes-core/packagegroup/nativesdk-packagegroup-sdk-host.bbappend
index b3fdd680..d0c26c2a 100644
--- a/recipes-core/packagegroup/nativesdk-packagegroup-sdk-host.bbappend
+++ b/recipes-core/packagegroup/nativesdk-packagegroup-sdk-host.bbappend
@@ -1,5 +1,4 @@
RDEPENDS_${PN} += " \
- nativesdk-elftosb \
nativesdk-mxsldr \
nativesdk-u-boot-mkimage \
nativesdk-imx-usb-loader \
diff --git a/wic/imx-barebox.wks b/wic/imx-barebox.wks
deleted file mode 100644
index 596583d3..00000000
--- a/wic/imx-barebox.wks
+++ /dev/null
@@ -1,19 +0,0 @@
-# short-description: Create SD card image with a boot partition
-# long-description:
-# Create an image that can be written onto a SD card using dd for use
-# with i.MX SoC family
-# It uses barebox
-#
-# The disk layout used is:
-# - --------- ------------ --------------
-# | | barebox | bareboxenv | rootfs |
-# - --------- ------------ --------------
-# ^ ^ ^ ^ ^
-# | | | | |
-# 0 512B 512kiB 4MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
-#
-part barebox --source rawcopy --sourceparams="file=barebox.bin,skip=512" --ondisk mmcblk --no-table
-part bareboxenv --source rawcopy --sourceparams="file=bareboxenv.bin" --ondisk mmcblk --no-table --align 512
-part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096
-
-bootloader --ptable msdos