aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-fsl-ppc/recipes-kernel/auto-resp/ar_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/auto-resp/ar_git.bb b/meta-fsl-ppc/recipes-kernel/auto-resp/ar_git.bb
index 81a94a04..52d9f57d 100644
--- a/meta-fsl-ppc/recipes-kernel/auto-resp/ar_git.bb
+++ b/meta-fsl-ppc/recipes-kernel/auto-resp/ar_git.bb
@@ -14,6 +14,10 @@ export KERNEL_PATH
INHIBIT_PACKAGE_STRIP = "1"
+do_compile_prepend() {
+ sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile
+}
+
do_install(){
install -d ${D}/lib/modules/${KERNEL_VERSION}
install -d ${D}${bindir}