aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch44
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb (renamed from recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb)10
2 files changed, 50 insertions, 4 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch
new file mode 100644
index 00000000..4e861a5d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch
@@ -0,0 +1,44 @@
+From e4c96421700ecd008814bceceaf03f0ee9323c02 Mon Sep 17 00:00:00 2001
+From: Yuqing Zhu <carol.zhu@nxp.com>
+Date: Thu, 27 Sep 2018 16:00:55 +0800
+Subject: [PATCH] imx-gst1.0-plugin: Fix ion.h header inclusion to be standard
+
+NXP "solution" was to manually copy the header to include/linux.
+Let's point the Makefile to the proper (mainline) location instead:
+https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
+
+Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
+---
+ configure.ac | 2 +-
+ libs/gstimxcommon.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7b2709d..d94e3a8 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -216,7 +216,7 @@ dnl check ion allocator headfile
+ old_CFLAGS=$CFLAGS
+ PKG_CHECK_MODULES(GST, gstreamer-$GST_MAJORMINOR >= 1.14, CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-allocators-1.0`",\
+ CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-bad-allocators-1.0`")
+-AC_CHECK_HEADERS([linux/ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no")
++AC_CHECK_HEADERS([ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no")
+ AM_CONDITIONAL(USE_ION, test "x$HAVE_ION" = "xyes")
+ CFLAGS=$old_CFLAGS
+
+diff --git a/libs/gstimxcommon.c b/libs/gstimxcommon.c
+index eb808b9..c02ab5f 100644
+--- a/libs/gstimxcommon.c
++++ b/libs/gstimxcommon.c
+@@ -26,7 +26,7 @@
+ #include <linux/version.h>
+ #include <linux/dma-buf.h>
+ #ifdef USE_ION
+-#include <linux/ion.h>
++#include <ion.h>
+ #endif
+ const char *dev_ion = "/dev/ion";
+
+--
+1.9.1
+
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
index 00182bbd..07a52c67 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
@@ -21,10 +21,12 @@ LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https"
-SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2"
+SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA"
-SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH}"
-SRCREV = "ded3b04018ca71306da9bc38b0037b9ea99abd29"
+SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH} \
+ file://0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch \
+"
+SRCREV = "23dd0315c7087e1c8eba836b9a458d7906187c7e"
S = "${WORKDIR}/git"
@@ -44,7 +46,7 @@ PLATFORM_mx8 = "MX8"
# Todo add a mechanism to map possible build targets
EXTRA_OECONF = "PLATFORM=${PLATFORM} \
- CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \
+ CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/drivers/staging/android/uapi" \
CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"