aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb26
1 files changed, 8 insertions, 18 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index 99c1293d..d7651fbc 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -14,30 +14,19 @@ python() {
}
DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \
-fixes of QorIQ ARM and QorIQ PPC targets, the recipe assumes that glx enable \
-config option is changed to --enable-opengl. The recipe only works for FSL \
+fixes of QorIQ ARM and QorIQ PPC targets. The recipe only works for FSL \
QorIQ machines. The poky version should be used for native/nativesdk build."
LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-# This means QEMU v2.2.0 with FSL specific patches applied
-PV = "2.2.0+${SRCPV}"
-
-# FIXME: this recipe requires poky's qemu.inc which assumes version 2.3
-# where glx enable config option changed to --enable-opengl. For now we
-# restore it, but we should remove the following lines when upgrading
-# to qemu 2.3:
-PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
-# remove not supported PACKAGECONFIG by this v2.2.0 based recipe
-PACKAGECONFIG[gnutls] = ""
+# remove not supported PACKAGECONFIG by this recipe
PACKAGECONFIG[gcrypt] = ""
PACKAGECONFIG[nettle] = ""
PACKAGECONFIG[nss] = ""
-RDEPENDS_${PN}_append = " gnutls"
-SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.9.x"
-SRCREV = "8362a298c4feef33c84d7db2d111af18bd29ef86"
+SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v2.0.x"
+SRCREV = "4b846e9b2b15660abace52dd27a406af08c4212d"
# add ptest patches
SRC_URI_append = "\
@@ -49,6 +38,7 @@ S = "${WORKDIR}/git"
QEMU_TARGETS_qoriq-ppc = "ppc"
QEMU_TARGETS_qoriq-arm = "arm"
+QEMU_TARGETS_qoriq_arm64 = "aarch64"
PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl'
EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
@@ -56,9 +46,9 @@ EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
-PACKAGECONFIG_append = " libusb"
+PACKAGECONFIG_append = " aio libusb"
-inherit pkgconfig
+DISABLE_STATIC = ""
# Append build host pkg-config paths for native target since the host may provide sdl
do_configure_prepend() {
@@ -67,7 +57,7 @@ do_configure_prepend() {
do_configure_append () {
if ! grep 'CONFIG_FDT=y' config-host.mak; then
- echo "CONFIG_RDMA=y" >> config-host.mak
+ echo "CONFIG_RDMA=y" >> config_host_mak
fi
}