aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch40
-rw-r--r--recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch28
-rw-r--r--recipes-security/optee/optee-test-qoriq_git.bb1
3 files changed, 29 insertions, 40 deletions
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch
deleted file mode 100644
index bad7c5e0..00000000
--- a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d877fddcef79e856193b9b0a3a3089c22151047f Mon Sep 17 00:00:00 2001
-From: Chunrong Guo <chunrong.guo@nxp.com>
-Date: Fri, 29 Jun 2018 15:49:34 +0800
-Subject: [PATCH] fix build failure with GCC 8
-
-Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
----
- host/xtest/Makefile | 2 ++
- host/xtest/adbg/src/adbg_run.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/host/xtest/Makefile b/host/xtest/Makefile
-index 832cba2..d95899d 100644
---- a/host/xtest/Makefile
-+++ b/host/xtest/Makefile
-@@ -139,6 +139,8 @@ CFLAGS += -Wall -Wcast-align -Werror \
- -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
- -Wshadow -Wstrict-prototypes -Wswitch-default \
- -Wwrite-strings \
-+ -Wno-stringop-overflow \
-+ -Wno-array-bounds \
- -Wno-missing-field-initializers -Wno-format-zero-length
- endif
-
-diff --git a/host/xtest/adbg/src/adbg_run.c b/host/xtest/adbg/src/adbg_run.c
-index 406e429..3b57bbb 100644
---- a/host/xtest/adbg/src/adbg_run.c
-+++ b/host/xtest/adbg/src/adbg_run.c
-@@ -100,7 +100,7 @@ int Do_ADBG_AppendToSuite(
- snprintf(p, size, "%s+%s", Dest_p->SuiteID_p,
- Source_p->SuiteID_p);
- else
-- strncpy(p, Source_p->SuiteID_p, size);
-+ memcpy(p, Source_p->SuiteID_p, size);
- free((void *)Dest_p->SuiteID_p);
- Dest_p->SuiteID_p = p;
-
---
-1.8.3.1
-
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch
new file mode 100644
index 00000000..9b912777
--- /dev/null
+++ b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch
@@ -0,0 +1,28 @@
+From 79330c8383e02e91a355964a3cc7b932d03c2517 Mon Sep 17 00:00:00 2001
+From: Chunrong Guo <chunrong.guo@nxp.com>
+Date: Wed, 10 Jul 2019 11:09:01 +0200
+Subject: [PATCH] fix build failure with GCC 9
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
+---
+ host/xtest/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/host/xtest/Makefile b/host/xtest/Makefile
+index e4e2881..e86e056 100644
+--- a/host/xtest/Makefile
++++ b/host/xtest/Makefile
+@@ -152,7 +152,7 @@ CFLAGS += -Wall -Wcast-align -Werror \
+ -Wmissing-include-dirs -Wmissing-noreturn \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
+ -Wshadow -Wstrict-prototypes -Wswitch-default \
+- -Wwrite-strings \
++ -Wwrite-strings -Wno-format-overflow \
+ -Wno-missing-field-initializers -Wno-format-zero-length
+ endif
+
+--
+2.7.4
+
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb
index bb0c30d1..1c6ca22e 100644
--- a/recipes-security/optee/optee-test-qoriq_git.bb
+++ b/recipes-security/optee/optee-test-qoriq_git.bb
@@ -9,6 +9,7 @@ DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native"
inherit pythonnative
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \
+ file://0001-fix-build-failure-with-GCC-9.patch \
"
S = "${WORKDIR}/git"