aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch13
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend5
2 files changed, 17 insertions, 1 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch
new file mode 100644
index 00000000..a245d79a
--- /dev/null
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch
@@ -0,0 +1,13 @@
+Index: git/src/plugins/platforms/eglfs/eglfs-plugin.pro
+===================================================================
+--- git.orig/src/plugins/platforms/eglfs/eglfs-plugin.pro 2017-01-04 16:54:05.000000000 -0600
++++ git/src/plugins/platforms/eglfs/eglfs-plugin.pro 2017-01-04 16:56:25.000000000 -0600
+@@ -2,6 +2,8 @@
+
+ QT += platformsupport-private eglfs_device_lib-private
+
++CONFIG += egl
++
+ SOURCES += $$PWD/qeglfsmain.cpp
+
+ OTHER_FILES += $$PWD/eglfs.json
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 03748711..a69dbec8 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,12 +1,15 @@
# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
# Copyright (C) 2016 O.S. Systems Software LTDA.
# Copyright (C) 2016 Freescale Semiconductor
+# Copyright 2017 NXP
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append_imxgpu2d = "file://0014-Add-IMX-GPU-support.patch"
SRC_URI_append_imxgpu3d = " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://0015-Add-eglfs-to-IMX-GPU.patch', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
+ 'file://0015-Add-eglfs-to-IMX-GPU.patch \
+ file://0016-Configure-eglfs-with-egl-pkg-config.patch', d)} \
"
PACKAGECONFIG_GL_imxpxp = "gles2"