aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/isp-imx/isp-imx/0001-run.sh-fix-bashism.patch23
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.6.0.bb5
2 files changed, 26 insertions, 2 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-run.sh-fix-bashism.patch b/recipes-bsp/isp-imx/isp-imx/0001-run.sh-fix-bashism.patch
new file mode 100644
index 00000000..715bed2a
--- /dev/null
+++ b/recipes-bsp/isp-imx/isp-imx/0001-run.sh-fix-bashism.patch
@@ -0,0 +1,23 @@
+From 7070abd558e753b89955a966bb83e11f5a7b8462 Mon Sep 17 00:00:00 2001
+From: Chris Dimich <Chris.Dimich@boundarydevices.com>
+Date: Wed, 17 Feb 2021 14:06:26 -0800
+Subject: [PATCH 1/1] run.sh: fix bashism
+
+Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com>
+---
+ imx/run.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/imx/run.sh b/imx/run.sh
+index c0d676ae7..ebeb7a6e7 100755
+--- a/imx/run.sh
++++ b/imx/run.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # Start the isp_media_server in the configuration from user
+ # (c) NXP 2020
+--
+2.29.0
+
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.6.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.6.0.bb
index fcf9a14a..8dd8c898 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.6.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.6.0.bb
@@ -8,8 +8,9 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=cf3f9b8d09bc3926b1
inherit fsl-eula-unpack cmake systemd
SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
- file://0001-start_isp.sh-fix-test-to-be-generic.patch;patchdir=.. \
file://0001-BufferManager.h-add-missing-header-file.patch;patchdir=.. \
+ file://0001-run.sh-fix-bashism.patch;patchdir=.. \
+ file://0001-start_isp.sh-fix-test-to-be-generic.patch;patchdir=.. \
"
SRC_URI[md5sum] = "2246009411af32b1e02fbb0b242a0fc0"
@@ -69,7 +70,7 @@ do_install() {
fi
}
-RDEPENDS_${PN} = "libdrm libpython3 bash"
+RDEPENDS_${PN} = "libdrm libpython3"
PACKAGES = "${PN} ${PN}-dev ${PN}-dbg"