aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch16
-rwxr-xr-xrecipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch34
2 files changed, 25 insertions, 25 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch
index 32b31953..747b62c5 100644
--- a/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch
+++ b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch
@@ -1,4 +1,4 @@
-From e99c36dfdce3e0f393eeaca6c2790b566f72d6a8 Mon Sep 17 00:00:00 2001
+From cc06048dcd722049f92ab17958760bd798fb4781 Mon Sep 17 00:00:00 2001
From: Shengjiu Wang <b02247@freescale.com>
Date: Thu, 5 Jun 2014 17:37:47 +0800
Subject: [PATCH] add conf for multichannel support in imx
@@ -189,10 +189,10 @@ index 0000000..a51509e
+
+# vim: ft=alsaconf
diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am
-index ee7991b..b08acae 100644
+index 00999f0..fbf0697 100644
--- a/src/conf/cards/Makefile.am
+++ b/src/conf/cards/Makefile.am
-@@ -54,7 +54,9 @@ cfg_files = aliases.conf \
+@@ -58,7 +58,9 @@ cfg_files = aliases.conf \
VIA8237.conf \
VX222.conf \
VXPocket.conf \
@@ -204,18 +204,18 @@ index ee7991b..b08acae 100644
if BUILD_ALISP
cfg_files += aliases.alisp
diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf
-index 4a92fb2..46430c2 100644
+index 18a920f..2c422ee 100644
--- a/src/conf/cards/aliases.conf
+++ b/src/conf/cards/aliases.conf
-@@ -55,6 +55,8 @@ AV100 cards.CMI8788
- AV200 cards.CMI8788
- CMI8786 cards.CMI8788
+@@ -57,6 +57,8 @@ CMI8786 cards.CMI8788
CMI8787 cards.CMI8788
+ pistachio cards.pistachio-card
+ VC4-HDMI cards.vc4-hdmi
+cs42888-audio cards.CS42888
+imx-hdmi-soc cards.IMX-HDMI
<confdir:pcm/default.conf>
<confdir:pcm/dmix.conf>
--
-1.8.0
+2.7.4
diff --git a/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch b/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
index 3cbd55a2..4d28a77f 100755
--- a/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
+++ b/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
@@ -1,4 +1,4 @@
-From af227bfcf02c5dd446e670f8367761a63c1b531f Mon Sep 17 00:00:00 2001
+From 93607819d90ddf9bbdad8bbbe4af5d917ca572dc Mon Sep 17 00:00:00 2001
From: Shengjiu Wang <shengjiu.wang@freescale.com>
Date: Tue, 10 May 2016 15:09:26 +0800
Subject: [PATCH 2/2] pcm: Don't store the state for SND_PCM_STATE_SUSPENDED
@@ -20,50 +20,50 @@ Signed-off-by: Shengjiu Wang <shengjiu.wang@freescale.com>
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/pcm/pcm_dmix.c b/src/pcm/pcm_dmix.c
-index b26a5c7..bd35d73 100644
+index a6a8f3a..89c07d1 100644
--- a/src/pcm/pcm_dmix.c
+++ b/src/pcm/pcm_dmix.c
-@@ -451,9 +451,9 @@ static snd_pcm_state_t snd_pcm_dmix_state(snd_pcm_t *pcm)
+@@ -466,9 +466,9 @@ static snd_pcm_state_t snd_pcm_dmix_state(snd_pcm_t *pcm)
+ snd_pcm_state_t state;
state = snd_pcm_state(dmix->spcm);
switch (state) {
- case SND_PCM_STATE_XRUN:
- case SND_PCM_STATE_SUSPENDED:
case SND_PCM_STATE_DISCONNECTED:
dmix->state = state;
+ case SND_PCM_STATE_SUSPENDED:
return state;
- default:
- break;
+ case SND_PCM_STATE_XRUN:
+ if ((err = snd_pcm_direct_slave_recover(dmix)) < 0)
diff --git a/src/pcm/pcm_dshare.c b/src/pcm/pcm_dshare.c
-index 58e47bb..433b100 100644
+index 7cdfea2..e0b4ea7 100644
--- a/src/pcm/pcm_dshare.c
+++ b/src/pcm/pcm_dshare.c
-@@ -241,9 +241,9 @@ static snd_pcm_state_t snd_pcm_dshare_state(snd_pcm_t *pcm)
+@@ -261,9 +261,9 @@ static snd_pcm_state_t snd_pcm_dshare_state(snd_pcm_t *pcm)
+ snd_pcm_state_t state;
state = snd_pcm_state(dshare->spcm);
switch (state) {
- case SND_PCM_STATE_XRUN:
- case SND_PCM_STATE_SUSPENDED:
case SND_PCM_STATE_DISCONNECTED:
dshare->state = state;
+ case SND_PCM_STATE_SUSPENDED:
return state;
- default:
- break;
+ case SND_PCM_STATE_XRUN:
+ if ((err = snd_pcm_direct_slave_recover(dshare)) < 0)
diff --git a/src/pcm/pcm_dsnoop.c b/src/pcm/pcm_dsnoop.c
-index 576c35b..a3b221f 100644
+index 539b671..03df6ff 100644
--- a/src/pcm/pcm_dsnoop.c
+++ b/src/pcm/pcm_dsnoop.c
-@@ -205,9 +205,9 @@ static snd_pcm_state_t snd_pcm_dsnoop_state(snd_pcm_t *pcm)
+@@ -212,9 +212,9 @@ static snd_pcm_state_t snd_pcm_dsnoop_state(snd_pcm_t *pcm)
+ snd_pcm_state_t state;
state = snd_pcm_state(dsnoop->spcm);
switch (state) {
- case SND_PCM_STATE_XRUN:
- case SND_PCM_STATE_SUSPENDED:
case SND_PCM_STATE_DISCONNECTED:
dsnoop->state = state;
+ case SND_PCM_STATE_SUSPENDED:
return state;
- default:
- break;
+ case SND_PCM_STATE_XRUN:
+ if ((err = snd_pcm_direct_slave_recover(dsnoop)) < 0)
--
-1.9.1
+2.7.4