aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch24
-rw-r--r--recipes-bsp/apptrk/apptrk/no-strip.patch20
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb31
3 files changed, 0 insertions, 75 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
deleted file mode 100644
index 6b4a0e83..00000000
--- a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Upstream-Status: Pending
-
-Signed-off-by: Chunrong Guo <B40290@freescale.com>
-
-
- for fix the following error:
- |install: cannot create regular file /usr/bin/apptrk
- |No such file or directory
-
-
---- a/Makefileold 2014-12-21 23:46:26.872329032 -0600
-+++ b/Makefile 2014-12-21 23:47:33.724326646 -0600
-@@ -89,9 +89,9 @@
- # Other Targets
- install: all
- if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi
-- install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
-+ install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
- if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi
-- install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
-+ install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
-
- clean:
- -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG)
diff --git a/recipes-bsp/apptrk/apptrk/no-strip.patch b/recipes-bsp/apptrk/apptrk/no-strip.patch
deleted file mode 100644
index a8cf6205..00000000
--- a/recipes-bsp/apptrk/apptrk/no-strip.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Disable stripping of binaries
-
-We don't want to strip these as this is handled separately at package
-time.
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Chunrong Guo <B40290@freescale.com>
-
---- a/Makefileold 2015-01-07 03:45:32.786477574 -0600
-+++ b/Makefile 2015-01-07 03:46:28.426475588 -0600
-@@ -62,7 +62,7 @@
- # CFLAGS += -DENABLE_64BIT_SUPPORT
-
-
--LDFLAGS += -s
-+
-
- # Add inputs and outputs from these tool invocations to the build variables
-
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
deleted file mode 100644
index 6016d42d..00000000
--- a/recipes-bsp/apptrk/apptrk_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "Debug agent for Freescale CodeWarrior"
-SECTION = "apptrk"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
-
-DEPENDS = "elfutils"
-
-inherit kernel-arch
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;branch=sdk-v2.0.x \
- file://apptrk-install-create-all-components-of-DEST.patch \
- file://no-strip.patch \
-"
-SRCREV = "873f44ca6b219508f738825299453d92975fb897"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE_qoriq-arm = "ARCH=arm"
-
-CFLAGS_append = " -I${STAGING_INCDIR} -ISource/Linux -ISource/Portable"
-CFLAGS_append_qoriq-arm = "-ISource/Linux_ARM -ISource/ARM"
-CFLAGS_append_qoriq-ppc += "-ISource/Linux_PA -ISource/PA -DPPC"
-CFLAGS_append_powerpc64 += "-DENABLE_64BIT_SUPPORT"
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-}
-
-COMPATIBLE_MACHINE = "(qoriq)"
-PACKAGE_ARCH = "${MACHINE_SOCARCH}"
-