aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch40
-rw-r--r--recipes-security/optee/optee-test-qoriq_git.bb5
2 files changed, 43 insertions, 2 deletions
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch
new file mode 100644
index 00000000..bad7c5e0
--- /dev/null
+++ b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch
@@ -0,0 +1,40 @@
+From d877fddcef79e856193b9b0a3a3089c22151047f Mon Sep 17 00:00:00 2001
+From: Chunrong Guo <chunrong.guo@nxp.com>
+Date: Fri, 29 Jun 2018 15:49:34 +0800
+Subject: [PATCH] fix build failure with GCC 8
+
+Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
+---
+ host/xtest/Makefile | 2 ++
+ host/xtest/adbg/src/adbg_run.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/host/xtest/Makefile b/host/xtest/Makefile
+index 832cba2..d95899d 100644
+--- a/host/xtest/Makefile
++++ b/host/xtest/Makefile
+@@ -139,6 +139,8 @@ CFLAGS += -Wall -Wcast-align -Werror \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
+ -Wshadow -Wstrict-prototypes -Wswitch-default \
+ -Wwrite-strings \
++ -Wno-stringop-overflow \
++ -Wno-array-bounds \
+ -Wno-missing-field-initializers -Wno-format-zero-length
+ endif
+
+diff --git a/host/xtest/adbg/src/adbg_run.c b/host/xtest/adbg/src/adbg_run.c
+index 406e429..3b57bbb 100644
+--- a/host/xtest/adbg/src/adbg_run.c
++++ b/host/xtest/adbg/src/adbg_run.c
+@@ -100,7 +100,7 @@ int Do_ADBG_AppendToSuite(
+ snprintf(p, size, "%s+%s", Dest_p->SuiteID_p,
+ Source_p->SuiteID_p);
+ else
+- strncpy(p, Source_p->SuiteID_p, size);
++ memcpy(p, Source_p->SuiteID_p, size);
+ free((void *)Dest_p->SuiteID_p);
+ Dest_p->SuiteID_p = p;
+
+--
+1.8.3.1
+
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb
index 880bd6f6..06b8f642 100644
--- a/recipes-security/optee/optee-test-qoriq_git.bb
+++ b/recipes-security/optee/optee-test-qoriq_git.bb
@@ -9,7 +9,8 @@ DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native"
inherit pythonnative
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \
- "
+ file://0001-fix-build-failure-with-GCC-8.patch \
+"
S = "${WORKDIR}/git"
SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00"
@@ -20,7 +21,7 @@ TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta"
EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \
- TEEC_EXPORT=${TEEC_EXPORT} \
+ CFG_ARM64=y \
CROSS_COMPILE_HOST=${TARGET_PREFIX} \
CROSS_COMPILE_TA=${TARGET_PREFIX} \
V=1 \