aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch25
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.14.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
new file mode 100644
index 00000000..3cd25014
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
@@ -0,0 +1,25 @@
+From 844ce11967bca7b7f68c6cb459e02c9a10f32574 Mon Sep 17 00:00:00 2001
+From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
+Date: Tue, 3 Jul 2018 15:06:29 +0800
+Subject: [PATCH] fix gcc8 build error
+
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index d6db01a..85d9d6c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -422,6 +422,8 @@ LINUXINCLUDE := \
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
+ -fno-strict-aliasing -fno-common -fshort-wchar \
++ -Wno-packed-not-aligned \
++ -Wno-tautological-compare \
+ -Werror-implicit-function-declaration \
+ -Wno-format-security \
+ -std=gnu89
+--
+1.8.3.1
+
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb
index f4af8d52..bceacf35 100644
--- a/recipes-kernel/linux/linux-qoriq_4.14.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.14.bb
@@ -7,8 +7,9 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
+ file://0001-fix-gcc8-build-error.patch \
"
-SRCREV = "dfe1b1320d85c5eea99af54dfbf5e9923c3392cc"
+SRCREV = "b09b730fcb1cbcbaa71ff8a84eafd1c2454f7e55"
S = "${WORKDIR}/git"