aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa/usdpaa/usdpaa_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-dpaa/usdpaa/usdpaa_git.bb b/recipes-dpaa/usdpaa/usdpaa_git.bb
index 769224a3..ae3c5108 100644
--- a/recipes-dpaa/usdpaa/usdpaa_git.bb
+++ b/recipes-dpaa/usdpaa/usdpaa_git.bb
@@ -9,18 +9,18 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS += "flib"
-SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;branch=sdk-v1.9.x"
-SRCREV = "b73546dc923d9f3df92af08c2ebaf36d83ab96ea"
+SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;branch=sdk-v2.0.x"
+SRCREV = "940d8f7f989c567b8c554ddba7bc4f0f4f21eb11"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"'
-export ARCH="${TARGET_ARCH}"
+WRAP_ARCH ?= "${TARGET_ARCH}"
+WRAP_ARCH_ls1043ardb = "arm64"
+EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}" ARCH="${WRAP_ARCH}"'
do_install () {
- oe_runmake install DESTDIR=${D}
+ oe_runmake install LIBDIR=${BASELIB} DESTDIR=${D}
}
PARALLEL_MAKE_pn-${PN} = ""
-
-COMPATIBLE_MACHINE = "(qoriq-ppc)"
+COMPATIBLE_MACHINE = "(qoriq-ppc|ls1043a)"