aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-02 17:25:12 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-05-05 16:23:48 -0300
commita2f542394e752d025cbe9f9dd9ed4489fb16409b (patch)
tree3f297176e16193d3ba00b5aed3122c5f55378856 /dynamic-layers
parent35a46644ad9397711aaa67ec384222ab6e89d655 (diff)
downloadmeta-freescale-a2f542394e752d025cbe9f9dd9ed4489fb16409b.tar.gz
meta-freescale-a2f542394e752d025cbe9f9dd9ed4489fb16409b.tar.bz2
meta-freescale-a2f542394e752d025cbe9f9dd9ed4489fb16409b.zip
qtwayland: drop xcomposite-egl, xcomposite-glx packageconfig for mx8
NXP dropped native X11 support for i.MX 8(X). with xcomposite-glx: qtwayland fails in configure with: | ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-client && features.opengl && !features.opengles2 && features.xlib && libs.xcomposite && libs.glx' failed. | ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-server && features.opengl && !features.opengles2 && libs.xcomposite && libs.glx' failed. with xcomposte-egl: qtwayland fails during compile starting with: | .../qwaylandxcompositeeglclientbufferintegration.cpp:140:59: error: cannot convert 'Display*' {aka '_XDisplay*'} to 'EGLNativeDisplayType' {aka 'wl_display*'} | integration->mEglDisplay = eglGetDisplay(integration->mDisplay); | ~~~~~~~~~~~~~^~~~~~~~ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 7f61dc50..afc728c1 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1,2 +1,5 @@
# etnaviv mesa does not have glx
PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx"
+
+# i.MX8 does never provide native x11, so required dependencies are not met
+PACKAGECONFIG_remove_mx8 = "xcomposite-egl xcomposite-glx"