aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/include/maintainers.inc23
-rw-r--r--conf/layer.conf24
-rw-r--r--conf/machine/include/intel-common-pkgarch.inc15
-rw-r--r--conf/machine/include/intel-core2-32-common.inc7
-rw-r--r--conf/machine/include/intel-corei7-64-common.inc7
-rw-r--r--conf/machine/include/intel-quark-common.inc12
-rw-r--r--conf/machine/include/meta-intel.inc52
-rw-r--r--conf/machine/include/qemu-intel.inc19
-rw-r--r--conf/machine/include/qemuboot-intel.inc19
-rw-r--r--conf/machine/intel-core2-32.conf35
-rw-r--r--conf/machine/intel-corei7-64.conf46
-rw-r--r--conf/machine/intel-quark.conf33
12 files changed, 292 insertions, 0 deletions
diff --git a/conf/include/maintainers.inc b/conf/include/maintainers.inc
new file mode 100644
index 00000000..995ff339
--- /dev/null
+++ b/conf/include/maintainers.inc
@@ -0,0 +1,23 @@
+# This file contains a list of recipe maintainers for meta-intel
+
+RECIPE_MAINTAINER_pn-core-image-rt = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-core-image-rt-sdk = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-efilinux = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-gma500-gfx-check = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-intel-gpu-tools = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-intel-microcode = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-intel-minimal-initramfs = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-iucode-tool = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-libva-intel-driver = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-libyami = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-libyami-utils = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-linux-intel = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-linux-intel-rt = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-lms7 = "TBD"
+RECIPE_MAINTAINER_pn-lms8 = "TBD"
+RECIPE_MAINTAINER_pn-rmc = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-rmc-db = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-thermald = "Swee Aun Khor <swee.aun.khor@intel.com>"
+RECIPE_MAINTAINER_pn-va-intel = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-xf86-video-ast = "Wei Tee Ng <wei.tee.ng@intel.com>"
+RECIPE_MAINTAINER_pn-xf86-video-mga = "Wei Tee Ng <wei.tee.ng@intel.com>"
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 00000000..53f831e0
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,24 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}:${LAYERDIR}/common"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/common/recipes-*/*/*.bb \
+ ${LAYERDIR}/common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "intel"
+BBFILE_PATTERN_intel := "^${LAYERDIR}/common/"
+BBFILE_PRIORITY_intel = "5"
+
+# Additional license directories.
+LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
+
+LAYERDEPENDS_intel = "core"
+LAYERRECOMMENDS_intel = "dpdk intel-qat"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_intel = "4"
+LAYERSERIES_COMPAT_intel = "rocko"
+
+
+require ${LAYERDIR}/conf/include/maintainers.inc
diff --git a/conf/machine/include/intel-common-pkgarch.inc b/conf/machine/include/intel-common-pkgarch.inc
new file mode 100644
index 00000000..d0f208bd
--- /dev/null
+++ b/conf/machine/include/intel-common-pkgarch.inc
@@ -0,0 +1,15 @@
+INTEL_COMMON_PACKAGE_ARCH ?= "${TUNE_PKGARCH}-intel-common"
+PACKAGE_ARCH_pn-linux-intel = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-intel-rt = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-intel-tiny = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-intel-dev = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-yocto = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-yocto-rt = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-yocto-tiny = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-linux-yocto-dev = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-intel-microcode = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-backport-iwlwifi = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-ixgbe = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_ARCH_pn-ixgbevf = "${INTEL_COMMON_PACKAGE_ARCH}"
+PACKAGE_EXTRA_ARCHS_append += "${INTEL_COMMON_PACKAGE_ARCH}"
+MACHINEOVERRIDES =. "${INTEL_COMMON_PACKAGE_ARCH}:"
diff --git a/conf/machine/include/intel-core2-32-common.inc b/conf/machine/include/intel-core2-32-common.inc
new file mode 100644
index 00000000..8c469499
--- /dev/null
+++ b/conf/machine/include/intel-core2-32-common.inc
@@ -0,0 +1,7 @@
+#
+# Common configuration for all MACHINEs of the intel-core2 type
+#
+
+DEFAULTTUNE ?= "core2-32"
+require conf/machine/include/tune-core2.inc
+require conf/machine/include/x86-base.inc
diff --git a/conf/machine/include/intel-corei7-64-common.inc b/conf/machine/include/intel-corei7-64-common.inc
new file mode 100644
index 00000000..00282569
--- /dev/null
+++ b/conf/machine/include/intel-corei7-64-common.inc
@@ -0,0 +1,7 @@
+#
+# Common configuration for all MACHINES of the intel-corei7-64 type
+#
+
+DEFAULTTUNE ?= "corei7-64"
+require conf/machine/include/tune-corei7.inc
+require conf/machine/include/x86-base.inc
diff --git a/conf/machine/include/intel-quark-common.inc b/conf/machine/include/intel-quark-common.inc
new file mode 100644
index 00000000..f7cfe146
--- /dev/null
+++ b/conf/machine/include/intel-quark-common.inc
@@ -0,0 +1,12 @@
+#
+# Common configuration for all MACHINES of the intel-quark type
+#
+
+DEFAULTTUNE ?= "i586-nlp-32"
+require conf/machine/include/tune-i586-nlp.inc
+require conf/machine/include/x86-base.inc
+
+# gnutls padlock code uses CMOV instruction in assembly which
+# is not valid for Quark.
+EXTRA_OECONF_append_pn-gnutls_intel-quark = " --disable-padlock"
+EXTRA_OECONF_append_pn-openssl_intel-quark = " no-asm"
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
new file mode 100644
index 00000000..34a672c0
--- /dev/null
+++ b/conf/machine/include/meta-intel.inc
@@ -0,0 +1,52 @@
+#
+# BSP variables and settings specific to the meta-intel layer.
+# You must include the meta-intel layer in your bblayers.conf
+# to use them.
+#
+
+#
+# XSERVER subcomponents, used to build the XSERVER variable
+#
+
+# Soft set linux-yocto as preferred kernel like x86-base.inc
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-intel"
+PREFERRED_PROVIDER_virtual/kernel_poky-tiny ?= "linux-intel"
+PREFERRED_PROVIDER_virtual/kernel_linuxstdbase ?= "linux-yocto"
+PREFERRED_VERSION_linux-intel ?= "4.9%"
+
+# for Xserver older than 1.13.0
+OLD_XSERVER_X86_EXT = "xserver-xorg-extension-dri \
+ xserver-xorg-extension-dri2 \
+ xserver-xorg-extension-extmod \
+ xserver-xorg-extension-dbe \
+ "
+
+XSERVER_X86_MATROX_MGA = "xf86-video-mga \
+ "
+
+XSERVER_X86_ASPEED_AST = "xf86-video-ast \
+ "
+
+# include the user space intel microcode loading support in the generated images.
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS_append = "${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', ' intel-microcode', '', d)} thermald"
+
+# recommended extra packages common to all intel machines
+MACHINE_EXTRA_RRECOMMENDS_append = " kernel-modules linux-firmware"
+
+# for the early boot time kernel microcode loading support,
+# merge the microcode data in the final initrd image.
+INITRD_LIVE_prepend = "${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', '${DEPLOY_DIR_IMAGE}/microcode.cpio ', '', d)}"
+
+DISK_SIGNATURE_UUID ??= "deadbeef-dead-beef-dead-beefdeadbeef"
+
+EFI_PROVIDER ?= "rmc-boot"
+
+# Add general MACHINEOVERRIDE for meta-intel
+MACHINEOVERRIDES =. "intel-x86-common:"
+
+# Definition of (more or less) suitable virtual machines.
+require conf/machine/include/qemuboot-intel.inc
+
+# Ensure that the extra tools needed by qemu are built when building images
+# and tweak machine definition to make the result more usable under qemu.
+require conf/machine/include/qemu-intel.inc
diff --git a/conf/machine/include/qemu-intel.inc b/conf/machine/include/qemu-intel.inc
new file mode 100644
index 00000000..81510404
--- /dev/null
+++ b/conf/machine/include/qemu-intel.inc
@@ -0,0 +1,19 @@
+# Similar to meta/conf/machine/include/qemu.inc but influences the
+# distro content (in particular the kernel) less than qemu.inc.
+
+# Ensure that qemu gets built when building images.
+EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"
+
+# Build ovmf firmware for uefi support in qemu.
+EXTRA_IMAGEDEPENDS += "ovmf"
+
+# runqemu uses virtio, so we have to enable the corresponding
+# kernel drivers.
+KERNEL_FEATURES_INTEL_COMMON += "cfg/virtio.scc"
+
+# Other useful extensions which are not enabled by default:
+# rng-tools to take advantage of qemu's virtio-rng-pci device.
+# MACHINE_EXTRA_RRECOMMENDS += "rng-tools"
+
+# Creates the necessary .qemuboot.conf file for each image.
+IMAGE_CLASSES += "qemuboot"
diff --git a/conf/machine/include/qemuboot-intel.inc b/conf/machine/include/qemuboot-intel.inc
new file mode 100644
index 00000000..cb52330b
--- /dev/null
+++ b/conf/machine/include/qemuboot-intel.inc
@@ -0,0 +1,19 @@
+# For runqemu
+IMAGE_CLASSES += "qemuboot"
+QB_SYSTEM_NAME_intel-core2-32 = "qemu-system-i386"
+QB_CPU_intel-core2-32 = "-cpu coreduo"
+QB_CPU_KVM_intel-core2-32 = "-cpu kvm32"
+
+QB_SYSTEM_NAME_intel-corei7-64 = "qemu-system-x86_64"
+QB_CPU_intel-corei7-64 = "-cpu Nehalem"
+QB_CPU_KVM_intel-corei7-64 = "-cpu kvm64"
+
+QB_SYSTEM_NAME_intel-quark = "qemu-system-i386"
+QB_CPU_intel-quark = "-cpu coreduo"
+QB_CPU_KVM_intel-quark = "-cpu kvm32"
+
+QB_AUDIO_DRV = "alsa"
+QB_AUDIO_OPT = "-soundhw ac97,es1370"
+QB_KERNEL_CMDLINE_APPEND = "vga=0 uvesafb.mode_option=640x480-32 oprofile.timer=1 uvesafb.task_timeout=-1"
+# Add the 'virtio-rng-pci' device otherwise the guest may run out of entropy
+QB_OPT_APPEND = "-vga vmware -show-cursor -usb -usbdevice tablet -device virtio-rng-pci"
diff --git a/conf/machine/intel-core2-32.conf b/conf/machine/intel-core2-32.conf
new file mode 100644
index 00000000..abe6f901
--- /dev/null
+++ b/conf/machine/intel-core2-32.conf
@@ -0,0 +1,35 @@
+#@TYPE: Machine
+#@NAME: intel-core2-32
+
+#@DESCRIPTION: Machine configuration for 32 bit Intel Core 2 CPU (and later) with MMX, SSE, SSE2, SSE3, and SSSE3 instruction set support. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
+
+require conf/machine/include/meta-intel.inc
+require conf/machine/include/intel-core2-32-common.inc
+require conf/machine/include/intel-common-pkgarch.inc
+
+MACHINE_FEATURES += "pcbios efi"
+MACHINE_FEATURES += "va-impl-intel"
+MACHINE_FEATURES += "wifi 3g nfc"
+MACHINE_FEATURES += "intel-ucode"
+
+MACHINE_HWCODECS ?= "va-intel gstreamer1.0-vaapi"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "gma500-gfx-check"
+
+XSERVER ?= "${XSERVER_X86_BASE} \
+ ${XSERVER_X86_EXT} \
+ ${XSERVER_X86_FBDEV} \
+ ${XSERVER_X86_I915} \
+ ${XSERVER_X86_I965} \
+ ${XSERVER_X86_MODESETTING} \
+ ${XSERVER_X86_VESA} \
+ ${XSERVER_X86_ASPEED_AST} \
+ "
+
+SYSLINUX_OPTS = "serial 0 115200"
+SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyPCH0"
+APPEND += "rootwait console=ttyS0,115200 console=ttyPCH0,115200 console=tty0"
+
+IMAGE_FSTYPES += "wic"
+WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}"
+do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
diff --git a/conf/machine/intel-corei7-64.conf b/conf/machine/intel-corei7-64.conf
new file mode 100644
index 00000000..78a1f6e9
--- /dev/null
+++ b/conf/machine/intel-corei7-64.conf
@@ -0,0 +1,46 @@
+#@TYPE: Machine
+#@NAME: intel-corei7-64
+
+#@DESCRIPTION: Machine configuration for 64 bit Intel Core i7 CPU (and later) with MMX, SSE, SSE2, SSE3, and SSSE3 instruction set support. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
+
+require conf/machine/include/meta-intel.inc
+require conf/machine/include/intel-corei7-64-common.inc
+require conf/machine/include/intel-common-pkgarch.inc
+
+MACHINE_FEATURES += "pcbios efi"
+MACHINE_FEATURES += "va-impl-intel"
+MACHINE_FEATURES += "wifi 3g nfc"
+MACHINE_FEATURES += "intel-ucode"
+
+MACHINE_HWCODECS ?= "va-intel gstreamer1.0-vaapi"
+
+MACHINE_EXTRA_RRECOMMENDS += "lms8"
+
+# Enable optional dpdk:
+COMPATIBLE_MACHINE_pn-dpdk = "intel-corei7-64"
+COMPATIBLE_MACHINE_pn-dpdk-dev-libibverbs = "intel-corei7-64"
+DPDK_TARGET_MACHINE ?= "atm"
+
+# Enable optional QAT items:
+COMPATIBLE_MACHINE_pn-openssl-qat = "intel-corei7-64"
+COMPATIBLE_MACHINE_pn-qat16 = "intel-corei7-64"
+COMPATIBLE_MACHINE_pn-zlib-qat = "intel-corei7-64"
+
+XSERVER ?= "${XSERVER_X86_BASE} \
+ ${XSERVER_X86_EXT} \
+ ${XSERVER_X86_FBDEV} \
+ ${XSERVER_X86_I915} \
+ ${XSERVER_X86_I965} \
+ ${XSERVER_X86_MATROX_MGA} \
+ ${XSERVER_X86_MODESETTING} \
+ ${XSERVER_X86_VESA} \
+ ${XSERVER_X86_ASPEED_AST} \
+ "
+
+SYSLINUX_OPTS = "serial 0 115200"
+SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyS2"
+APPEND += "rootwait console=ttyS0,115200 console=tty0"
+
+IMAGE_FSTYPES += "wic"
+WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}"
+do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
diff --git a/conf/machine/intel-quark.conf b/conf/machine/intel-quark.conf
new file mode 100644
index 00000000..17e8c52f
--- /dev/null
+++ b/conf/machine/intel-quark.conf
@@ -0,0 +1,33 @@
+#@TYPE: Machine
+#@NAME: quark
+
+#@DESCRIPTION: Machine configuration for Quark systems
+
+require conf/machine/include/meta-intel.inc
+require conf/machine/include/intel-quark-common.inc
+require conf/machine/include/intel-common-pkgarch.inc
+
+#Avoid pulling in GRUB
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ""
+
+MACHINE_FEATURES = "efi usb"
+MACHINE_FEATURES += "intel-ucode"
+
+SERIAL_CONSOLE = "115200 ttyS1"
+APPEND += "rootwait console=ttyS1,115200 console=tty0"
+
+# Bypass the default labels which also has "install" option in OE.
+#
+# We don't need to do this when constructing direct-boot image with
+# wic. But EFI installer in hddimg image doesn't work on quark now,
+# so we only provide a live-boot entry in boot menu for images in
+# hddimg format.
+
+LABELS_LIVE = "boot"
+
+# Ensure that the Lock prefix is omitted for the kernel"
+KERNEL_EXTRA_ARGS = "EXTRA_CFLAGS=-Wa,-momit-lock-prefix=yes"
+
+IMAGE_FSTYPES += "wic"
+WKS_FILE ?= "galileodisk-sd.wks"
+do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"