aboutsummaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf24
1 files changed, 24 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 00000000..53f831e0
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,24 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}:${LAYERDIR}/common"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/common/recipes-*/*/*.bb \
+ ${LAYERDIR}/common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "intel"
+BBFILE_PATTERN_intel := "^${LAYERDIR}/common/"
+BBFILE_PRIORITY_intel = "5"
+
+# Additional license directories.
+LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
+
+LAYERDEPENDS_intel = "core"
+LAYERRECOMMENDS_intel = "dpdk intel-qat"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_intel = "4"
+LAYERSERIES_COMPAT_intel = "rocko"
+
+
+require ${LAYERDIR}/conf/include/maintainers.inc