aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README2
-rw-r--r--recipes-extended/dpdk/dpdk.inc2
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch40
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch48
-rw-r--r--recipes-extended/dpdk/dpdk_17.11.8.bb19
-rw-r--r--recipes-extended/dpdk/dpdk_18.11.8.bb (renamed from recipes-extended/dpdk/dpdk_18.11.2.bb)2
6 files changed, 4 insertions, 109 deletions
diff --git a/README b/README
index 7430eec6..81703cfb 100644
--- a/README
+++ b/README
@@ -21,7 +21,7 @@ Guidelines for submitting patches
====================================
Please submit any patches against meta-dpdk to the meta-intel
-mailing list (meta-intel@yoctoproject.org). Also, if your patches are
+mailing list (meta-intel@lists.yoctoproject.org). Also, if your patches are
available via a public git repository, please also include a URL to
the repo and branch containing your patches as that makes it easier
for maintainers to grab and test your patches.
diff --git a/recipes-extended/dpdk/dpdk.inc b/recipes-extended/dpdk/dpdk.inc
index 9b048816..6ac1d86c 100644
--- a/recipes-extended/dpdk/dpdk.inc
+++ b/recipes-extended/dpdk/dpdk.inc
@@ -179,3 +179,5 @@ FILES_${PN}-examples += " \
FILES_${PN}-test += " \
${INSTALL_PATH}/test \
"
+
+CVE_PRODUCT = "data_plane_development_kit"
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
deleted file mode 100644
index 55f0c15f..00000000
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
-From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
-Date: Fri, 2 Sep 2016 15:48:52 +0800
-Subject: [PATCH] dpdk: fix for parellel make issue
-
-To make sure that the path of libraries should be correct and
-libraries will be build before, And available at the time of
-linking example apps.
-
-Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
-
----
- examples/Makefile | 1 +
- examples/ethtool/ethtool-app/Makefile | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/examples/Makefile b/examples/Makefile
-index 17ecf7f64cda..2a8e805b85a7 100644
---- a/examples/Makefile
-+++ b/examples/Makefile
-@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
- DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
- DIRS-y += cmdline
- DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
-+DEPDIRS-y += examples/ethtool/lib
- DIRS-y += ethtool
- DIRS-y += exception_path
- DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
-diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
-index 4cd9efdd574b..d3c709ab2fef 100644
---- a/examples/ethtool/ethtool-app/Makefile
-+++ b/examples/ethtool/ethtool-app/Makefile
-@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
- CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
- CFLAGS += $(WERROR_FLAGS)
-
-+LDLIBS += -L$(ETHTOOL_LIB_PATH)/
- LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
- LDLIBS += -lrte_ethtool
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch b/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch
deleted file mode 100644
index 70a8decf..00000000
--- a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From a385972c3675dd2b4792ab5b3cf7a536e6f9846c Mon Sep 17 00:00:00 2001
-From: Reshma Pattan <reshma.pattan@intel.com>
-Date: Thu, 2 May 2019 10:33:34 +0100
-Subject: [PATCH] mk: disable warning for packed member pointer
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-gcc 9 on Fedora 30 gives an error
-"taking address of packed member may result in an
-unaligned pointer value" warnings.
-
-For clang builds this warning is already disabled,
-so disable "-Waddress-of-packed-member" for gcc builds
-also.
-
-Snippet of build error:
-lib/librte_eal/linux/eal/eal_memalloc.c: In function ‘alloc_seg_walk’:
-lib/librte_eal/linux/eal/eal_memalloc.c:768:12: error:
-taking address of packed member of ‘struct rte_mem_config’ may result
-in an unaligned pointer value [-Werror=address-of-packed-member]
- 768 | cur_msl = &mcfg->memsegs[msl_idx];
- | ^~~~~~~~~~~~~~~~~~~~~~~
-
-Signed-off-by: Reshma Pattan <reshma.pattan@intel.com>
-Tested-by: David Marchand <david.marchand@redhat.com>
-Upstream-Status: Backport
-Signed-off-by: He Zhe <zhe.he@windriver.com>
----
- mk/toolchain/gcc/rte.vars.mk | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
-index d8b99fa..b852fcf 100644
---- a/mk/toolchain/gcc/rte.vars.mk
-+++ b/mk/toolchain/gcc/rte.vars.mk
-@@ -87,5 +87,8 @@ WERROR_FLAGS += -Wimplicit-fallthrough=2
- WERROR_FLAGS += -Wno-format-truncation
- endif
-
-+# disable packed member unalign warnings
-+WERROR_FLAGS += -Wno-address-of-packed-member
-+
- export CC AS AR LD OBJCOPY OBJDUMP STRIP READELF
- export TOOLCHAIN_CFLAGS TOOLCHAIN_LDFLAGS TOOLCHAIN_ASFLAGS
---
-2.7.4
-
diff --git a/recipes-extended/dpdk/dpdk_17.11.8.bb b/recipes-extended/dpdk/dpdk_17.11.8.bb
deleted file mode 100644
index 004e1854..00000000
--- a/recipes-extended/dpdk/dpdk_17.11.8.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-include dpdk.inc
-
-STABLE = "-stable"
-BRANCH = "17.11"
-SRCREV = "25d4497a91d2631397e541a32381c51cd4cdd2f3"
-
-LICENSE = "LGPLv2 & GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe\
- file://LICENSE.LGPL;md5=4fbd65380cdd255951079008b364516c"
-
-SRC_URI += "\
- file://dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch \
- file://dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch \
-"
-
-do_install_append () {
- # Remove the unneeded dir
- rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app
-}
diff --git a/recipes-extended/dpdk/dpdk_18.11.2.bb b/recipes-extended/dpdk/dpdk_18.11.8.bb
index 7a3dcdbd..8a282438 100644
--- a/recipes-extended/dpdk/dpdk_18.11.2.bb
+++ b/recipes-extended/dpdk/dpdk_18.11.8.bb
@@ -2,7 +2,7 @@ include dpdk.inc
STABLE = "-stable"
BRANCH = "18.11"
-SRCREV = "06c4b12a5968caea61e96f7d6bd29d2726fbe255"
+SRCREV = "b80cf96c33fd91619c613b7c0877f4ebe175d48c"
LICENSE = "BSD-3-Clause & LGPLv2.1 & GPLv2"
LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \