aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb')
-rw-r--r--recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb b/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb
new file mode 100644
index 0000000..dc81604
--- /dev/null
+++ b/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.8.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Runtime libraries from OSX"
+LICENSE = "Proprietary"
+
+COMPATIBLE_HOST = ".*-darwin.*"
+
+SRC_URI = "file://OSX-sdk.zip \
+ file://LICENSE"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=03fe683ef28b9ddfe7f658a0f4b3b80e"
+
+S = "${WORKDIR}/OSX-sdk"
+#B = "${WORKDIR}/build-${TARGET_SYS}"
+
+inherit nativesdk
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+PROVIDES += "virtual/nativesdk-libc"
+PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-initial"
+PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-for-gcc"
+
+# Work around pulling in eglibc for now...
+PROVIDES += "virtual/nativesdk-libintl"
+PROVIDES += "virtual/nativesdk-libiconv"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install () {
+ cp -r ${S}/* ${D}/
+}
+
+FILES_${PN} = "/usr"
+FILES_${PN}-staticdev = "/usr/lib/*.a"
+
+sysroot_stage_all() {
+ sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
+}
+