aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend')
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
new file mode 100644
index 0000000..33c5813
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
@@ -0,0 +1,10 @@
+
+LTO_darwin = "--disable-lto"
+
+do_install_append_darwin () {
+ ln -s ${STAGING_DIR_TARGET}/${target_exec_prefix}/ ${D}/${exec_prefix}/${TARGET_SYS}
+}
+
+sysroot_stage_all_append_darwin () {
+ sysroot_stage_dir ${D}${exec_prefix}/${TARGET_SYS} ${SYSROOT_DESTDIR}${exec_prefix}/${TARGET_SYS}
+}