aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb')
-rw-r--r--recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb b/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb
new file mode 100644
index 0000000..f4803a1
--- /dev/null
+++ b/recipes-devtools/osx-runtime/nativesdk-osx-runtime_10.10.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "Runtime libraries from OSX"
+LICENSE = "Proprietary"
+
+COMPATIBLE_HOST = ".*-darwin.*"
+
+SRC_URI = "file://OSX-sdk.zip \
+ file://remove_unsupported_attribute_availability_with_message_for_gcc_osx10.10.patch \
+ file://fix_typedef_dispatch_block_t.patch \
+ file://fsevents-clang.patch \
+ file://foundation_framework_headers_clang.patch \
+ file://LICENSE"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=03fe683ef28b9ddfe7f658a0f4b3b80e"
+
+S = "${WORKDIR}/OSX-sdk"
+#B = "${WORKDIR}/build-${TARGET_SYS}"
+
+inherit nativesdk
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+PROVIDES += "virtual/nativesdk-libc"
+PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-initial"
+PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-for-gcc"
+
+# Work around pulling in eglibc for now...
+PROVIDES += "virtual/nativesdk-libintl"
+PROVIDES += "virtual/nativesdk-libiconv"
+
+CFLAGS[unexport] = "1"
+CXXFLAGS[unexport] = "1"
+CPPFLAGS[unexport] = "1"
+LDFLAGS[unexport] = "1"
+TARGET_CFLAGS[unexport] = "1"
+TARGET_CXXFLAGS[unexport] = "1"
+TARGET_CPPFLAGS[unexport] = "1"
+TARGET_LDFLAGS[unexport] = "1"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install () {
+ mkdir ${D}/usr
+ cp -r ${S}/usr/* ${D}/usr/
+ mkdir -p ${D}/System/Library/Frameworks
+ cp -r ${S}/System/Library/Frameworks/* ${D}/System/Library/Frameworks/
+ mkdir -p ${D}/System/Library/PrivateFrameworks
+ cp -r ${S}/System/Library/PrivateFrameworks/* ${D}/System/Library/PrivateFrameworks/
+}
+
+FILES_${PN} = "/usr /System/Library/Frameworks"
+FILES_${PN} += "/usr /System/Library/PrivateFrameworks"
+FILES_${PN}-staticdev = "/usr/lib/*.a"
+
+sysroot_stage_all() {
+ sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
+}
+