aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
AgeCommit message (Collapse)AuthorFilesLines
2017-11-27postgresql: updates to get things working with systemdMark Asselstine4-126/+77
Convert the sysvinit code to instead work with systemd. We are no longer able to make use of postinst scripts as we need to perform setup after the postgresql service is started, this will have 'knock-on' effects for other postinst, such as for keystone. Changing these postinst to "one time" services buys us greater control and easier readability than the postinst scripts, so overall this is a good change. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-27apache: changes to support systemdMark Asselstine1-2/+3
Auto start apache2 and adapt how we change the logging location from /var/apache2/logs to /var/log/apache2. Sysvinit specific changes are removed as we only plan to support systemd. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-27meta-openstack: initial move to use systemdMark Asselstine8-6/+43
Add instructions to the README.setup on how to configure the build to use systemd. The remaining changes are a bit of hack and slash to get the builds to succeed. The 'hacking' only touches core openstack component recipes which are all in various states of broken anyways, so these changes will not affect any current meta-cloud-services users. All of these will be corrected shortly. Most users of OpenStack have long ago made the move to systemd, by following suit we can take advantage of the better support for service files along with matching most OpenStack documentation. The remaining sysvinit parts will be removed as we get the openstack components updated and back to a working state. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-21python-debtcollector: uprev to v1.17.1Mark Asselstine1-2/+2
Although the current version is OK as far as dependent requirements.txt there appears to be some issues with the older version. The uprev is due, so let's get to it. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-21python-enum-compat: initial version v0.0.2Mark Asselstine1-0/+10
This will allow packages with 'enum-compat' in their requirements.txt to not complain/error, even though the real dependency is on 'enum34'. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-21python-eventlet: add RDEPENDS for enum-compatMark Asselstine1-0/+1
The true dependency is for 'enum34' but if the system is checking against the requirements.txt it might complain if 'enum-compat' is not present. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-17python-*: switch remaining (https) pypi recipes to use the pypi classMark Asselstine76-561/+100
The original commit to switch pypi recipes to use the pypi.bbclass only addressed the urgent need to get the recipes using "http" converted. This change is the same but converts the remaining pypi recipes which were already uing "https". Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes which use 'zip' or 'bz2' extensions we need to set PYPI_PACKAGE_EXT. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-15python-logutils: upgrade to 0.3.5zhengrq1-4/+4
1) Upgrade python-logutils from 0.3.3 to 0.3.5. 2) Modify LIC_FILES_CHKSUM as Copyright (c) in LICENSE.txt has been changed from 2008-2013 to 2008-2017. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
2017-11-15python-paramiko: upgrade to 2.4.0zhengrq1-3/+3
1) Upgrade python-paramiko from 2.2.1 to 2.4.0. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
2017-11-15python-jsonschema: drop our recipe in favor of the one in meta-pythonMark Asselstine2-17/+1
The current v2.5.1 recipe is slightly broken (needs PYPI_PACKAGE_EXT = "zip" added). But regardless the current v2.5.1 recipe is unused since we are picking up the v2.6.0 in meta-python. Drop the unused/broken v2.5.1 recipe to clean things up. As with all our python recipes we will need to keep an eye on the version to ensure the are compatible, so add a PREF version to help track any skew that might develop. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-15python-*: fixup postinst scriptsMark Asselstine13-205/+185
Checking for "$D" and doing an "exit 1" now results in errors such as: [log_check] warning: %post(keystone-cronjobs-...) scriptlet failed, exit status 2 during image creation. Instead of escaping the script for "level-1" (image creation postinst) we wrap the "level-2" (first boot) postinst in an if statement. This also ensure the scriptlet in indentity.bbclass is less prone to behaving differently based on the postinsts defined in the classes which inherit 'identity'. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-*: switch remaining pypi recipes to use the pypi classMark Asselstine79-542/+124
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes using archived versions of packages we must set PYPI_SRC_URI to overwrite what the pypi class would derive. For example when the archive is a zip and not a tar.gz. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-horizon: uprev to latest stable/pikeMark Asselstine1-12/+13
Required version updates to satisfy requirements.txt: python-xstatic-angular, python-xstatic-angular-bootstrap, python-xstatic-angular-gettext, python-xstatic-bootstrap-scss, python-xstatic-bootswatch, python-xstatic-d3, python-xstatic-font-awesome, python-xstatic-jasmine, python-xstatic-jsencrypt, python-xstatic-roboto-fontface, python-xstatic-term.js. As well as the openstack *-clients. These uprev's have been completed in commit prior to this one. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-xstatic-*: uprev to required versionsMark Asselstine21-259/+212
The python-horizon requires specific versions of the various python-xstatic-* per its requirements.txt file. Being 'xtatic' packages these have no additional dependencies so the uprevs are mostly straitforward version updates with a check that the license hasn't changed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-novaclient: uprev to latest stable/pikeMark Asselstine1-9/+15
Updated runtime dependencies based on requirements.txt. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-neutronclient: uprev to latest stable/pikeMark Asselstine1-6/+10
Updated runtime dependencies based on requirements.txt. Required updates to python-cliff and python-osc-lib. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-cliff: uprev to v2.9.1Mark Asselstine1-10/+3
This uprev is required for the uprev of python-neutronclient to stable/pike. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-osc-lib: uprev to v1.7.0Mark Asselstine1-10/+3
This uprev is required for the uprev of python-neutronclient to stable/pike. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-glanceclient: uprev to latest stable/pikeMark Asselstine2-46/+15
Update runtime dependencies based on requirements.txt, drop old patches. Required a downrev of python-warlock as this verison is not compatible with v1.3.0. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-warlock: add v1.2.0 required by python-glanceclientMark Asselstine2-0/+22
Keep the newer v1.3.0 around but we need to ensure this version is in use so set a PREF version. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-cinderclient: uprev to latest stable/pikeMark Asselstine2-52/+15
Remove old patches and update runtime dependencies based on requirements.txt Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-ceilometerclient: uprev to latest stable/pikeMark Asselstine2-51/+9
Drop old patches and update runtime dependency list. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-14python-keystone: launch service via uwsgiMark Asselstine1-2/+3
The keystone-all has been removed upstream and all indication seem to show that using uwsgi is the new approach to launching this service. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-13python-keystone: uprev to latest stable/pikeMark Asselstine1-30/+35
Required updates to python-olso*, keystoneclient, keystonemiddleware and more. These updates have all been completed in commit prior to this uprev. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-13python-keystonemiddleware: uprev to latest stable/pikeMark Asselstine1-5/+18
Updated runtime dependencies based on requirements.txt. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-13python-keystoneclient: uprev to latest stable/pikeMark Asselstine3-90/+18
This package no longer contains bash-completions, so drop this part of the packaging. Remove old, no longer applicable patches. Update the list of runtime dependencies, based on required.txt. Requires the version update to python-django-openstack-auth. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-13python-keystoneauth1: uprev to v3.2.0Mark Asselstine1-9/+3
This uprev is required by the stable/pike version of python-django-openstack-auth, and others. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-13python-django-openstack-auth: uprev to latest stable/pikeMark Asselstine1-7/+12
This uprev is required to support the uprev of python-horizon to the latest stable/pike. Requires the uprevs to python-keystoneclient and python-keystoneauth1. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-oslo*: uprev to latest stable/pikeMark Asselstine19-69/+64
Uprev all of the existing 'oslo' packages to the latest commit on the stable/pike branch. This will allow us to prepare for the uprev of the main openstack components to stable/pike. Dependencies are been validated and uprev'd/added as needed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-eventlet: add v0.20.0Mark Asselstine2-1/+16
Version 0.21.0 is not compatible with python-oslo.service per its requirements.txt: python-eventlet !=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 So add the v0.20.0 and set it as the PREF'd version. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-kombu: uprev to v4.1.0Mark Asselstine4-44/+16
This version is required for python-oslo.messaging when moved to stable/pike. We can drop the v3.0.37 version as it is no longer required allowing us to only have one recipe. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-amqp: uprev to v2.2.2Mark Asselstine4-33/+14
This newer version is required by the new version of python-oslo.messaging found on stable/pike. Drop the old v1.4.9 so we only have the one recipe. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-vine: initial versionMark Asselstine1-0/+13
This python package is required for the v2.2.2 of python-amqp. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-tenacity: initial versionMark Asselstine1-0/+18
There is a recipe in meta-iot-cloud but it is old and if we can avoid pulling in yet another layer I think we are better off maintaining our own copy. This python package is required by the updated python-oslo.messaging verison for stable/pike. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-statsd: initial versionMark Asselstine1-0/+15
This python package is required by python-oslo.middleware. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-requestsexceptions: uprev to v1.3.0Mark Asselstine1-4/+2
Uprev required by python-os-client-config v1.28.0. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-stevedore: uprev to v1.27.1Mark Asselstine2-32/+20
This newer version is required by the latest keystone and others. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-sqlalchemy-migrate: upgrade to v0.11.0Mark Asselstine2-32/+22
This version is required by the latest version of keystone. The additional license was added since the source header has one license and the COPYING file has a different license, so better safe than sorry. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-xstatic-jquery-quicksearch: rename to python-xstatic-jquery.quicksearchMark Asselstine1-0/+0
Rename to match upstream name as well as match name used in requirements.txt to allow easier automation of dependency checks. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-xstatic-jquery-tablesorter: rename to python-xstatic-jquery.tablesorterMark Asselstine1-0/+0
By renaming we match the upstream naming convention. This allows for better automation around dependencies and requirements.txt. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-08python-msgpack: drop in favor of version in meta-openembeddedMark Asselstine1-17/+0
The bindings for python-msgpack are pretty lenient so we are not hugely concerned about having tight version control for this package. As such we can drop our recipe and simply use the one in meta-openembedded. We can always re-evaluate in the future if necessary, but for now this is one less thing to maintain. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-07python-keystone: remove use of the 'users' groupMark Asselstine1-2/+2
The use of the 'users' group was associated with the addition of apache vhost support. See commit bf51fa4f053a [python-keystone: Add apache vhost server.]. The directories and files needed to be readable by the same user running apache. Since the use of RSS, definiing a common group used by multiple recipes (apache and keystone in this case) becomes more involved and we need to use FILESYSTEM_PERMS_TABLES to accomplish this. Remove the use of the 'users' group until we can evaluate if this is still required and if so we have a proper FILESYSTEM_PERMS_TABLES solution in place. This will solve build failures for 'unknown group "users"' in the interim. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-07python-nova: sudoers.d match dir ownership/permsMark Asselstine1-1/+1
The sudoers.d directory is for all intents and purposes created and owned by the sudo package. We must therefor ensure we match the ownership and perms which sudo used to install this directory. Currently we don't so this results in an error when assembling the filesystem: file /etc/sudoers.d conflicts between attempted installs of \ nova-common-12.0.0+git0+6df6ad3ff3-r0.core2_64 and \ sudo-1.8.20p2-r0.core2_64 Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-07rabbitmq-server: add missing depends on coreutils-nativeMark Asselstine1-1/+10
With the move to RSS this missing dependency became a build issue, previously hidden by some other package fullfilling the dependency before this package was built. With RSS we need to ensure all first level dependencies are listed to avoid build failures. The build requires the 'fold' command which is provided by coreutils-native. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-07meta-openstack/README: drop meta-rubyMark Asselstine1-1/+0
meta-openembedded commit 6E7C9636D276 [meta-ruby: remove this now pretty empty layer] removed the meta-ruby layer from existence. We can therefor drop this layer dependency. Builds continue to work as the various ruby recipes exist, they have just been moved out of the 'language layer'. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-06python-httplib2: upgrade to 0.10.3zhengrq1-4/+4
1) Upgrade python-httplib2 from 0.9.2 to 0.10.3. 2) Modify LIC_FILES_CHKSUM as home-page in PKG-INFO has been changed from https://github.com/jcgregorio/httplib2 to https://github.com/httplib2/httplib2 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-06python-heatclient: upgrade to 1.9.0zhengrq1-2/+2
Upgrade python-heatclient from 0.6.0 to 1.9.0. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-02python-eventlet:upgrade to 0.21.0Huang Qiyu1-3/+3
Upgrade python-eventlet from 0.18.4 to 0.21.0. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-11-02python-happybase: upgrade to 1.1.0Huang Qiyu1-3/+3
Upgrade python-happybase 1.0.0 to 1.1.0. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-10-27xterm: remove bbappendKai Kang1-1/+0
Add freetype-native to DEPENDS has been done by PACKAGECONFIG 'xft'. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>