aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/celt051/celt051_git.bb4
-rw-r--r--recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch34
-rw-r--r--recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb (renamed from recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb)21
-rw-r--r--recipes-support/openldap/openldap_2.4.39.bb6
-rw-r--r--recipes-support/puppet-vswitch/puppet-vswitch_git.bb6
-rw-r--r--recipes-support/puppet/puppet_5.4.0.bb6
-rw-r--r--recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb4
-rw-r--r--recipes-support/ruby-shadow/ruby-shadow_git.bb6
-rw-r--r--recipes-support/spice/spice_git.bb24
9 files changed, 73 insertions, 38 deletions
diff --git a/recipes-support/celt051/celt051_git.bb b/recipes-support/celt051/celt051_git.bb
index ee388214..52c7cf38 100644
--- a/recipes-support/celt051/celt051_git.bb
+++ b/recipes-support/celt051/celt051_git.bb
@@ -9,7 +9,7 @@ with high quality. Unlike these formats CELT imposes very little delay \
on the signal, even less than is typical for speech centric formats \
like Speex, GSM, or G.729."
-LICENSE = "BSD"
+LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=375f60ab360d17f0172737036ff155b2"
PV = "0.5.1.3"
@@ -17,7 +17,7 @@ PR = "r0"
SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f"
-SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https"
+SRC_URI = "git://gitlab.xiph.org/xiph/celt.git;branch=compat-v0.5.1;protocol=https"
S = "${WORKDIR}/git"
diff --git a/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
new file mode 100644
index 00000000..86e9f7b4
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
@@ -0,0 +1,34 @@
+From fb9c5b955da462695e0a662aebfa13493eaf3978 Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Fri, 13 Oct 2023 22:28:25 +0800
+Subject: [PATCH] utils/Makefile.am: fix shebang for chsh.py and getent.py
+
+Update shebang to python3 for chsh.py and getent.py to fix QA issue:
+
+WARNING: nss-pam-ldapd-0.9.12-r0 do_package_qa: QA Issue: File
+/usr/share/nslcd-utils/chsh.py in package nss-pam-ldapd contains
+reference to TMPDIR
+File /usr/share/nslcd-utils/getent.py in package nss-pam-ldapd contains
+reference to TMPDIR [buildpaths]
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ utils/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+index a6bccd3..22a50d8 100644
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -39,5 +39,5 @@ install-data-hook:
+ set -ex; for cmd in getent chsh ; do \
+ [ -L $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ] || $(LN_S) $(utilsdir)/$$cmd.py $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ; \
+ chmod a+rx $(DESTDIR)$(utilsdir)/$$cmd.py ; \
+- sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
++ sed -i -e '1 s|/usr/bin/env python|/usr/bin/env python3|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
+ done
+--
+2.25.1
+
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
index dfa562f7..7f3b9e38 100644
--- a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
@@ -8,23 +8,24 @@ DESCRIPTION = "\
HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SECTION = "base"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "\
http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
+ file://0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch \
file://nslcd.init \
file://nslcd.service \
"
-inherit autotools distro_features_check
+inherit autotools features_check
REQUIRED_DISTRO_FEATURES = "pam"
-SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
-SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
+SRC_URI[md5sum] = "cc30ee0ab91d6c94b7a343ae09b5dc69"
+SRC_URI[sha256sum] = "c6d661e74693cbf531a790631ca93b73f291fb23cc39465b09deb8da2bfb0e14"
DEPENDS += "libpam openldap krb5"
@@ -34,14 +35,14 @@ EXTRA_OECONF = "\
--with-pam-seclib-dir=${base_libdir}/security \
"
-CONFFILES_${PN} += "${sysconfdir}/nslcd.conf"
+CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
-FILES_${PN} += "${base_libdir}/security ${datadir}"
-FILES_${PN}-dbg += "${base_libdir}/security/.debug"
+FILES:${PN} += "${base_libdir}/security ${datadir}"
+FILES:${PN}-dbg += "${base_libdir}/security/.debug"
LDAP_DN ?= "dc=my-domain,dc=com"
-do_install_append() {
+do_install:append() {
install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
@@ -57,4 +58,4 @@ inherit update-rc.d systemd
INITSCRIPT_NAME = "nslcd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE_${PN} = "nslcd.service"
+SYSTEMD_SERVICE:${PN} = "nslcd.service"
diff --git a/recipes-support/openldap/openldap_2.4.39.bb b/recipes-support/openldap/openldap_2.4.39.bb
index 3048c8ee..1083e3e3 100644
--- a/recipes-support/openldap/openldap_2.4.39.bb
+++ b/recipes-support/openldap/openldap_2.4.39.bb
@@ -164,7 +164,7 @@ PACKAGECONFIG[proxycache] = "--enable-proxycache=mod,--enable-proxycache=no,"
#--enable-mdb enable mdb database backend no|yes|mod no
PACKAGECONFIG[mdb] = "--enable-mdb=mod,--enable-mdb=no,"
-CPPFLAGS_append = " -D_GNU_SOURCE"
+CPPFLAGS:append = " -D_GNU_SOURCE"
do_configure() {
cp ${STAGING_DATADIR_NATIVE}/libtool/config/ltmain.sh ${S}/build
@@ -177,6 +177,6 @@ do_configure() {
oe_runconf
}
-FILES_${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libexecdir}/openldap/*.a ${libexecdir}/openldap/*.la ${libexecdir}/openldap/*.so"
-FILES_${PN}-dbg += "${libexecdir}/openldap/.debug"
+FILES:${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libexecdir}/openldap/*.a ${libexecdir}/openldap/*.la ${libexecdir}/openldap/*.so"
+FILES:${PN}-dbg += "${libexecdir}/openldap/.debug"
diff --git a/recipes-support/puppet-vswitch/puppet-vswitch_git.bb b/recipes-support/puppet-vswitch/puppet-vswitch_git.bb
index 86922aef..14c2dd7a 100644
--- a/recipes-support/puppet-vswitch/puppet-vswitch_git.bb
+++ b/recipes-support/puppet-vswitch/puppet-vswitch_git.bb
@@ -7,7 +7,7 @@ PV = "3.0.0"
SRCREV = "c374840910c823f7669cf2e1229c7df7192ae880"
SRC_URI = " \
- git://github.com/openstack/puppet-vswitch.git;branch=master \
+ git://github.com/openstack/puppet-vswitch.git;branch=master;protocol=https \
file://Add-gemspec.patch \
"
@@ -20,7 +20,7 @@ DEPENDS += " \
facter \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
ruby \
facter \
puppet \
@@ -28,5 +28,5 @@ RDEPENDS_${PN} += " \
RUBY_INSTALL_GEMS = "puppet-vswitch-${PV}.gem"
-do_install_append() {
+do_install:append() {
}
diff --git a/recipes-support/puppet/puppet_5.4.0.bb b/recipes-support/puppet/puppet_5.4.0.bb
index 54574e49..c207e40f 100644
--- a/recipes-support/puppet/puppet_5.4.0.bb
+++ b/recipes-support/puppet/puppet_5.4.0.bb
@@ -20,7 +20,7 @@ DEPENDS += " \
facter \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
ruby \
facter \
ruby-shadow \
@@ -34,9 +34,9 @@ INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
SYSTEMD_AUTO_ENABLE = "enable"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/puppet
install -d ${D}${sysconfdir}/puppet/manifests
install -d ${D}${sysconfdir}/puppet/modules
diff --git a/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb
index 2d3d9c2b..78ded052 100644
--- a/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb
+++ b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb
@@ -7,7 +7,7 @@ PV = "4.10.0"
SRCREV = "0b4822be3d2242e83c28ab7fed6c5817adc322d5"
SRC_URI = " \
- git://github.com/puppetlabs/puppetlabs-stdlib.git;branch=master \
+ git://github.com/puppetlabs/puppetlabs-stdlib.git;branch=master;protocol=https \
file://Add-gemspec.patch \
"
@@ -20,7 +20,7 @@ DEPENDS += " \
facter \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
ruby \
facter \
puppet \
diff --git a/recipes-support/ruby-shadow/ruby-shadow_git.bb b/recipes-support/ruby-shadow/ruby-shadow_git.bb
index e7db6d16..0c6fc60b 100644
--- a/recipes-support/ruby-shadow/ruby-shadow_git.bb
+++ b/recipes-support/ruby-shadow/ruby-shadow_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=137882914e5269b7268f0fe8e28a3f89"
PV = "2.5.0"
-SRC_URI = "git://github.com/apalmblad/ruby-shadow.git"
+SRC_URI = "git://github.com/apalmblad/ruby-shadow.git;branch=master;protocol=https"
SRCREV = "d2e822d8a8bda61f0774debbfce363a7347ed893"
S = "${WORKDIR}/git"
@@ -15,9 +15,9 @@ DEPENDS += " \
ruby \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
ruby \
"
RUBY_INSTALL_GEMS = "ruby-shadow-${PV}.gem"
-FILES_${PN}-dbg += "/usr/lib*/ruby/gems/*/gems/ruby-shadow-${PV}/.debug/shadow.so"
+FILES:${PN}-dbg += "/usr/lib*/ruby/gems/*/gems/ruby-shadow-${PV}/.debug/shadow.so"
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index c0fdd9c3..44e7ce15 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -10,7 +10,7 @@ environment - not only on its computer-server machine, but also from \
anywhere on the Internet and using a wide variety of machine \
architectures."
-LICENSE = "BSD & LGPLv2.1+"
+LICENSE = "BSD & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
PR = "r0"
@@ -26,9 +26,9 @@ SRCREV_spice-protocol = "784407f248e7f99d2bfcc9368f9acd1efb2b9617"
SRCREV_FORMAT = "spice_spice-common_spice-protocol"
-SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
- git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
+SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
+ git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common;branch=master \
+ git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol;branch=master \
"
SRC_URI += " \
@@ -45,12 +45,12 @@ SRC_URI += " \
S = "${WORKDIR}/git"
-inherit autotools gettext pythonnative python-dir pkgconfig
+inherit autotools gettext python3native python3-dir pkgconfig
-DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0"
+DEPENDS += "python3-native celt051 python3-pyparsing jpeg pixman alsa-lib glib-2.0"
export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
-export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
+export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python${PYTHON_BASEVERSION}/site-packages"
PACKAGECONFIG ?= "sasl"
@@ -62,15 +62,15 @@ PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
PACKAGES =+ "${PN}-protocol"
-LICENSE_${PN}-protocol = "BSD"
-FILES_${PN}-protocol += "${includedir}/spice-1"
-FILES_${PN}-protocol += "${datadir}/pkgconfig"
+LICENSE:${PN}-protocol = "BSD"
+FILES:${PN}-protocol += "${includedir}/spice-1"
+FILES:${PN}-protocol += "${datadir}/pkgconfig"
-do_configure_prepend() {
+do_configure:prepend() {
mkdir -p ${S}/spice-common/spice-protocol/m4
}
-do_install_append() {
+do_install:append() {
cd ${B}/spice-common/spice-protocol
oe_runmake DESTDIR="${D}" install
cd -