aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/spice/spice_git.bb')
-rw-r--r--recipes-support/spice/spice_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index c0fdd9c3..44e7ce15 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -10,7 +10,7 @@ environment - not only on its computer-server machine, but also from \
anywhere on the Internet and using a wide variety of machine \
architectures."
-LICENSE = "BSD & LGPLv2.1+"
+LICENSE = "BSD & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
PR = "r0"
@@ -26,9 +26,9 @@ SRCREV_spice-protocol = "784407f248e7f99d2bfcc9368f9acd1efb2b9617"
SRCREV_FORMAT = "spice_spice-common_spice-protocol"
-SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
- git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
+SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
+ git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common;branch=master \
+ git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol;branch=master \
"
SRC_URI += " \
@@ -45,12 +45,12 @@ SRC_URI += " \
S = "${WORKDIR}/git"
-inherit autotools gettext pythonnative python-dir pkgconfig
+inherit autotools gettext python3native python3-dir pkgconfig
-DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0"
+DEPENDS += "python3-native celt051 python3-pyparsing jpeg pixman alsa-lib glib-2.0"
export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
-export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
+export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python${PYTHON_BASEVERSION}/site-packages"
PACKAGECONFIG ?= "sasl"
@@ -62,15 +62,15 @@ PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
PACKAGES =+ "${PN}-protocol"
-LICENSE_${PN}-protocol = "BSD"
-FILES_${PN}-protocol += "${includedir}/spice-1"
-FILES_${PN}-protocol += "${datadir}/pkgconfig"
+LICENSE:${PN}-protocol = "BSD"
+FILES:${PN}-protocol += "${includedir}/spice-1"
+FILES:${PN}-protocol += "${datadir}/pkgconfig"
-do_configure_prepend() {
+do_configure:prepend() {
mkdir -p ${S}/spice-common/spice-protocol/m4
}
-do_install_append() {
+do_install:append() {
cd ${B}/spice-common/spice-protocol
oe_runmake DESTDIR="${D}" install
cd -