aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/glusterfs/glusterfs.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/glusterfs/glusterfs.inc')
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc72
1 files changed, 41 insertions, 31 deletions
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index 81ea65e1..c5f21c70 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -20,18 +20,20 @@ SRC_URI += "file://glusterd.init \
file://glusterd-change-port-range.patch \
file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
file://0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch \
+ file://0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch \
"
-LICENSE = "(LGPLv3+ | GPLv2) & GPLv3+ & LGPLv3+ & GPLv2+ & LGPLv2+ & LGPLv2.1+ & Apache-2.0"
+LICENSE = "(LGPL-3.0-or-later | GPL-2.0-only) & GPL-3.0-or-later & LGPL-3.0-or-later & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING-GPLV2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING-LGPLV3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://contrib/fuse-util/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-inherit autotools pkgconfig distutils3-base update-rc.d systemd
+inherit autotools pkgconfig setuptools3-base update-rc.d systemd
inherit python3-dir
+inherit bash-completion
-DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
- openssl python3 readline zlib liburcu util-linux glib-2.0 acl"
+DEPENDS += "openssl-native bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
+ openssl python3 readline zlib liburcu util-linux glib-2.0 acl ca-certificates ca-certificates-native liburing"
# rpc now comes from libtirpc instead of glibc
#
@@ -41,27 +43,31 @@ LDFLAGS += " -ltirpc"
EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
ac_cv_file__etc_SuSE_release=no \
ac_cv_file__etc_redhat_release=no \
- ac_cv_file__etc_centos_release=no \
+ ac_cv_file__etc_centos_release=no \
+ ac_cv_file__etc_os_release=no \
--with-mountutildir=${sbindir} \
--disable-fusermount \
TARGET_PYTHON=${bindir}/python3 \
PYTHON=${PYTHON} \
+ SSL_CERTS_DIR="${sysconfdir_native}/ssl/certs" \
BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \
BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \
"
-PACKAGECONFIG ??= "georeplication libibverbs"
-PACKAGECONFIG_remove_mipsarch = "libibverbs"
-PACKAGECONFIG_remove_arm = "libibverbs"
+PACKAGECONFIG ??= "georeplication"
PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync"
-PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm,"
+# PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm,"
PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,,"
PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
+PACKAGECONFIG[tcmalloc] = ",--without-tcmalloc,,"
-do_install_append() {
+# TODO: packageconfig for:
+# --disable-linux-io_uring
+
+do_install:append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/glusterd.init \
${D}${sysconfdir}/init.d/glusterd
@@ -108,29 +114,29 @@ INITSCRIPT_NAME = "glusterd"
INITSCRIPT_PARAMS = "start 20 5 3 2 . stop 80 0 1 6 ."
SYSTEMD_PACKAGES = "glusterfs-server"
-SYSTEMD_SERVICE_${PN} = "glusterd.service"
+SYSTEMD_SERVICE:${PN} = "glusterd.service"
SYSTEMD_AUTO_ENABLE = "disable"
# Allow plug-in symlinks.
-INSANE_SKIP_${PN} += "dev-so"
-INSANE_SKIP_${PN}-rdma += "dev-so"
-INSANE_SKIP_${PN}-fuse += "dev-so"
-INSANE_SKIP_${PN}-server += "dev-so"
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:${PN}-rdma += "dev-so"
+INSANE_SKIP:${PN}-fuse += "dev-so"
+INSANE_SKIP:${PN}-server += "dev-so"
PACKAGES += "${PN}-rdma ${PN}-geo-replication ${PN}-fuse ${PN}-server \
${PN}-api ${PN}-ocf"
-RDEPENDS_${PN} += "python3-core python3-json python3-ctypes bash"
-RDEPENDS_${PN}-ocf += "bash"
-RDEPENDS_${PN}-server += "bash"
-RDEPENDS_${PN}-geo-replication += "python3-core bash"
+RDEPENDS:${PN} += "python3-core python3-json python3-ctypes bash"
+RDEPENDS:${PN}-ocf += "bash"
+RDEPENDS:${PN}-server += "bash"
+RDEPENDS:${PN}-geo-replication += "python3-core bash"
-FILES_${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \
+FILES:${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \
${libdir}/glusterfs/${PV}/*/*/.debug \
${libdir}/glusterfs/${PV}/*/*/*/.debug \
${libexecdir}/glusterfs/.debug"
-FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
+FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
${libdir}/glusterfs/${PV}/rpc-transport/socket* \
${libdir}/glusterfs/${PV}/xlator/cluster \
${libdir}/glusterfs/${PV}/xlator/debug \
@@ -140,7 +146,7 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
${libdir}/glusterfs/${PV}/xlator/protocol/client* \
${libdir}/glusterfs/${PV}/xlator/system \
${libdir}/glusterfs/${PV}/xlator/testing \
- ${libdir}/glusterfs/${PV}/xlator/playground \
+ ${libdir}/glusterfs/${PV}/xlator/playground \
${libdir}/glusterfs/${PV}/xlator/meta.so \
${libdir}/glusterfs/ganesha \
${libdir}/glusterfs/glusterfs/glusterfind \
@@ -153,7 +159,7 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
${libdir}/libgfdb.so.* \
${libdir}/libgfxdr.so.* \
${libdir}/python*/site-packages \
- ${libexecdir}/glusterfs/gfevents \
+ ${libexecdir}/glusterfs/gfevents \
${libexecdir}/glusterfs/events \
${libexecdir}/glusterfs/glusterfind \
${libexecdir}/glusterfs/gfind_missing_files \
@@ -163,7 +169,10 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
${libexecdir}/glusterfs/peer_mountbroker \
${libexecdir}/glusterfs/peer_gsec_create \
${libexecdir}/glusterfs/gverify.sh \
+ ${libexecdir}/glusterfs/glfsheal \
+ ${libexecdir}/glusterfs/scripts/ \
${libexecdir}/glusterfs/peer_add_secret_pub \
+ ${libexecdir}/ganesha/ \
${localstatedir} \
${sysconfdir}/default/volatiles \
${sbindir}/glusterfs \
@@ -175,30 +184,31 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
${sbindir}/glustereventsd \
${sbindir}/gf_attach \
${sbindir}/*.py \
- ${sbindir}/gluster-setgfid2path \
+ ${sbindir}/gluster-setgfid2path \
${bindir}/ \
${sysconfdir}/glusterfs \
${sysconfdir}/ganesha \
${datadir}/glusterfs/* \
"
-FILES_${PN}-rdma = "${libdir}/glusterfs/${PV}/rpc-transport/rdma*"
+FILES:${PN}-rdma = "${libdir}/glusterfs/${PV}/rpc-transport/rdma*"
-FILES_${PN}-geo-replication = "${libexecdir}/glusterfs/gsyncd \
+FILES:${PN}-geo-replication = "${libexecdir}/glusterfs/gsyncd \
${libexecdir}/glusterfs/python/syncdaemon \
${libexecdir}/glusterfs/peer_georep-sshkey.py \
${libexecdir}/glusterfs/set_geo_rep_pem_keys.sh \
${sbindir}/gluster-georep-sshkey"
-FILES_${PN}-fuse = "${bindir}/fusermount-glusterfs \
+FILES:${PN}-fuse = "${bindir}/fusermount-glusterfs \
${libdir}/glusterfs/${PV}/xlator/mount \
${sbindir}/mount.glusterfs \
${base_sbindir}/mount.glusterfs"
-FILES_${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
+FILES:${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
${libdir}/glusterfs/${PV}/xlator/nfs \
${libdir}/glusterfs/${PV}/xlator/protocol/server* \
${libdir}/glusterfs/${PV}/xlator/storage \
+ ${libdir}/glusterfs/${PV}/cloudsync-plugins/ \
${sbindir}/gluster \
${sbindir}/glusterd \
${sysconfdir}/glusterfs/glusterd.vol \
@@ -208,11 +218,11 @@ FILES_${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
${systemd_system_unitdir}"
# Note: Debian package renaming produces libgfapi[0-9]+-*.*.rpm.
-FILES_${PN}-api = "${libdir}/libgfapi.so.*"
+FILES:${PN}-api = "${libdir}/libgfapi.so.*"
-FILES_${PN}-ocf = "${prefix}/lib/ocf"
+FILES:${PN}-ocf = "${prefix}/lib/ocf"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ]; then
/etc/init.d/populate-volatile.sh update
fi