aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb16
-rw-r--r--recipes-connectivity/consul/consul_git.bb20
-rw-r--r--recipes-connectivity/serf/hashicorp-serf_0.8.5.bb6
3 files changed, 23 insertions, 19 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
index 8419cb86..1393c912 100644
--- a/recipes-connectivity/consul/consul-migrate_git.bb
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD & MPL-2.0 & MIT"
LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul-migrate/LICENSE;md5=b278a92d2c1509760384428817710378"
GO_IMPORT = "github.com/hashicorp/consul-migrate"
-SRC_URI = "git://${GO_IMPORT}.git"
+SRC_URI = "https://${GO_IMPORT}.git;branch=master"
SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
S = "${WORKDIR}/git"
@@ -18,13 +18,13 @@ SRCREV_bolt = "c6ba97b89e0454fec9aa92e1d33a4e2c5fc1f631"
SRCREV_go-msgpack = "fa3f63826f7c23912c15263591e65d54d080b458"
SRC_URI += " \
- git://github.com/hashicorp/raft;name=raft;destsuffix=git/src/github.com/hashicorp/raft \
- git://github.com/armon/go-metrics;name=go-metrics;destsuffix=git/src/github.com/armon/go-metrics \
- git://github.com/hashicorp/raft-boltdb;name=raft-boltdb;destsuffix=git/src/github.com/hashicorp/raft-boltdb \
- git://github.com/hashicorp/raft-mdb;name=raft-mdb;destsuffix=git/src/github.com/hashicorp/raft-mdb \
- git://github.com/armon/gomdb;name=gomdb;destsuffix=git/src/github.com/armon/gomdb \
- git://github.com/boltdb/bolt;name=bolt;destsuffix=git/src/github.com/boltdb/bolt \
- git://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack \
+ https://github.com/hashicorp/raft;name=raft;destsuffix=git/src/github.com/hashicorp/raft;branch=master;protocol=https \
+ https://github.com/armon/go-metrics;name=go-metrics;destsuffix=git/src/github.com/armon/go-metrics;branch=master;protocol=https \
+ https://github.com/hashicorp/raft-boltdb;name=raft-boltdb;destsuffix=git/src/github.com/hashicorp/raft-boltdb;branch=master;protocol=https \
+ https://github.com/hashicorp/raft-mdb;name=raft-mdb;destsuffix=git/src/github.com/hashicorp/raft-mdb;branch=master;protocol=https \
+ https://github.com/armon/gomdb;name=gomdb;destsuffix=git/src/github.com/armon/gomdb;branch=master;protocol=https \
+ https://github.com/boltdb/bolt;name=bolt;destsuffix=git/src/github.com/boltdb/bolt;branch=master;protocol=https \
+ https://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack;branch=master;protocol=https \
"
inherit go
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b96499c4..0d084b0d 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -5,14 +5,14 @@ LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2
GO_IMPORT = "github.com/hashicorp/consul"
SRCREV = "944cc71026c007e7de9467ec3f38f0ad14464fcc"
-SRC_URI = "git://${GO_IMPORT}.git \
+SRC_URI = "git://${GO_IMPORT}.git;branch=main;protocol=https \
file://0001-Migration-Rename-imports-throughout.patch \
file://consul.service \
"
S = "${WORKDIR}/git"
-RDEPENDS_${PN}-dev_append = " bash"
+RDEPENDS:${PN}-dev:append = " bash"
# Temporarily workaround an issue with GO 1.12.1
# http://www.lyddzz.com/github_/golang/go/issues/30768
@@ -23,17 +23,21 @@ inherit systemd go
# Besides the hosts specified in goarch, we do not build for mips.
#
-COMPATIBLE_HOST_mipsarch = "null"
+COMPATIBLE_HOST:mipsarch = "null"
-SYSTEMD_SERVICE_${PN} = "consul.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "consul.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
-do_install_append() {
+do_compile:prepend () {
+ export GO111MODULE=off
+}
+
+do_install:append() {
install -d ${D}/${systemd_unitdir}/system
cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
}
-FILES_${PN} += "${systemd_unitdir}/system"
+FILES:${PN} += "${systemd_unitdir}/system"
#for i586, executable consul contains textrel
-INSANE_SKIP_${PN} += "textrel"
+INSANE_SKIP:${PN} += "textrel"
diff --git a/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
index 0b1517b1..8318400d 100644
--- a/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
+++ b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
@@ -17,7 +17,7 @@ LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=b278a92d2c15097603844288
require serf-vendor-licenses.inc
GO_IMPORT = "github.com/hashicorp/serf"
-SRC_URI = "git://${GO_IMPORT}.git;protocol=https"
+SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
PV = "0.8.5+git${SRCPV}"
SRCREV = "1d3fdf93bbe5002c5023da50402368a817488691"
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
inherit go
-RDEPENDS_${PN}-dev += "bash make"
+RDEPENDS:${PN}-dev += "bash make"
# Apache serf in oe-core is a completely different beast
-RCONFLICTS_${PN} = "serf"
+RCONFLICTS:${PN} = "serf"