aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/conf/layer.conf2
-rw-r--r--meta-openstack/recipes-devtools/python/python-eventlet_0.20.0.bb15
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index 302b6578..68590852 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -19,5 +19,5 @@ PREFERRED_VERSION_python-django = "1.8.6"
PREFERRED_VERSION_python-netaddr = "0.7.19"
PREFERRED_VERSION_python-sqlalchemy = "1.0.16"
PREFERRED_VERSION_python-requests = "2.13.0"
-
+PREFERRED_VERSION_python-eventlet = "0.20.0"
LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-openstack/recipes-devtools/python/python-eventlet_0.20.0.bb b/meta-openstack/recipes-devtools/python/python-eventlet_0.20.0.bb
new file mode 100644
index 00000000..9d3c0da5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-eventlet_0.20.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Highly concurrent networking library"
+HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
+
+SRC_URI[md5sum] = "057276232bf65f1db6aabf819e7ece6a"
+SRC_URI[sha256sum] = "2e17cda85f2003796f13de0e6c59a5253c0afd1f45dfc97bb9b6bfb8962f7895"
+
+inherit setuptools pypi
+
+RDEPENDS_${PN} += " \
+ python-enum34 \
+ python-greenlet \
+ "