aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-happybase.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb20
-rw-r--r--meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb2
3 files changed, 22 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-happybase.inc b/meta-openstack/recipes-devtools/python/python-happybase.inc
new file mode 100644
index 00000000..325b2d1e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-happybase.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Python library to interact with Apache HBase"
+HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
+
+SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
+SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
+
+inherit pypi
+
+do_install_append() {
+ perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
+ perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
+ for f in $perm_files; do
+ chmod 644 "${f}"
+ done
+}
diff --git a/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb b/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
index a8066b68..26e39a8d 100644
--- a/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
@@ -1,18 +1,2 @@
-DESCRIPTION = "Python library to interact with Apache HBase"
-HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
-
-SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
-SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
-
-inherit setuptools pypi
-
-do_install_append() {
- perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
- perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
- for f in $perm_files; do
- chmod 644 "${f}"
- done
-}
+inherit setuptools
+require python-happybase.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
new file mode 100644
index 00000000..8b5571bf
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-happybase.inc