aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-httpretty.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python-httpretty_0.9.6.bb19
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_0.9.6.bb3
3 files changed, 23 insertions, 17 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-httpretty.inc b/meta-openstack/recipes-devtools/python/python-httpretty.inc
new file mode 100644
index 00000000..f39e2834
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-httpretty.inc
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+#
+DESCRIPTION = "HTTP client mock for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=113a91608a1d89039af9393c39bcaa2c"
+
+SRC_URI[md5sum] = "3b881b519e0f405caaf8aaa63f3508c0"
+SRC_URI[sha256sum] = "01b52d45077e702eda491f4fe75328d3468fd886aed5dcc530003e7b2b5939dc"
+
+inherit pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
diff --git a/meta-openstack/recipes-devtools/python/python-httpretty_0.9.6.bb b/meta-openstack/recipes-devtools/python/python-httpretty_0.9.6.bb
index 68d79f33..8993807d 100644
--- a/meta-openstack/recipes-devtools/python/python-httpretty_0.9.6.bb
+++ b/meta-openstack/recipes-devtools/python/python-httpretty_0.9.6.bb
@@ -1,18 +1,3 @@
-#
-# Copyright (C) 2014 Wind River Systems, Inc.
-#
-DESCRIPTION = "HTTP client mock for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=113a91608a1d89039af9393c39bcaa2c"
-
-SRC_URI[md5sum] = "3b881b519e0f405caaf8aaa63f3508c0"
-SRC_URI[sha256sum] = "01b52d45077e702eda491f4fe75328d3468fd886aed5dcc530003e7b2b5939dc"
-
-inherit setuptools pypi
-
-DEPENDS += " \
- python-pip \
- "
+inherit setuptools
+require python-httpretty.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.6.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.6.bb
new file mode 100644
index 00000000..b9f7699a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.6.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-httpretty.inc
+