aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-fasteners.inc24
-rw-r--r--meta-openstack/recipes-devtools/python/python-fasteners_git.bb26
-rw-r--r--meta-openstack/recipes-devtools/python/python3-fasteners_git.bb2
3 files changed, 27 insertions, 25 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-fasteners.inc b/meta-openstack/recipes-devtools/python/python-fasteners.inc
new file mode 100644
index 00000000..6e5e5f0c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-fasteners.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "A python package that provides useful locks."
+HOMEPAGE = "https://github.com/harlowja/fasteners"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52"
+
+SRCNAME = "fasteners"
+
+PV = "0.15+git${SRCPV}"
+SRCREV = "75148cb679c351966cd4ad5e9d177048a0ea8380"
+
+SRC_URI = "git://github.com/harlowja/${SRCNAME}.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pbr \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pbr \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-fasteners_git.bb b/meta-openstack/recipes-devtools/python/python-fasteners_git.bb
index 2dd36981..3a7326bf 100644
--- a/meta-openstack/recipes-devtools/python/python-fasteners_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-fasteners_git.bb
@@ -1,26 +1,2 @@
-DESCRIPTION = "A python package that provides useful locks."
-HOMEPAGE = "https://github.com/harlowja/fasteners"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52"
-
-SRCNAME = "fasteners"
-
-PV = "0.15+git${SRCPV}"
-SRCREV = "75148cb679c351966cd4ad5e9d177048a0ea8380"
-
-SRC_URI = "git://github.com/harlowja/${SRCNAME}.git"
-
-S = "${WORKDIR}/git"
-
inherit setuptools
-
-DEPENDS += " \
- python-pip \
- python-pbr \
- "
-
-# RDEPENDS_default:
-RDEPENDS_${PN} += " \
- python-pbr \
- "
+require python-fasteners.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-fasteners_git.bb b/meta-openstack/recipes-devtools/python/python3-fasteners_git.bb
new file mode 100644
index 00000000..9b2053c1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-fasteners_git.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-fasteners.inc