aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient_git.bb24
2 files changed, 15 insertions, 46 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch
deleted file mode 100644
index 754d83fa..00000000
--- a/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
----
- glanceclient/openstack/common/apiclient/client.py | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/glanceclient/openstack/common/apiclient/client.py
-+++ b/glanceclient/openstack/common/apiclient/client.py
-@@ -90,6 +90,7 @@
- self.user_agent = user_agent or self.user_agent
-
- self.times = [] # [("item", starttime, endtime), ...]
-+ self.times_max_len = 200
- self.timings = timings
-
- # requests within the same session can reuse TCP connections from pool
-@@ -142,6 +143,12 @@
- def reset_timings(self):
- self.times = []
-
-+ def get_timings_max_len(self):
-+ return self.times_max_len
-+
-+ def set_timings_max_len(self, new_len):
-+ self.times_max_len = new_len
-+
- def request(self, method, url, **kwargs):
- """Send an http request with the specified characteristics.
-
-@@ -173,6 +180,9 @@
- if self.timings:
- self.times.append(("%s %s" % (method, url),
- start_time, time.time()))
-+ # remove oldest items until we maintain max length
-+ while len(self.times) > self.times_max_len:
-+ del self.times[0]
- self._http_log_resp(resp)
-
- if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
index 22dc854c..00ea2ab1 100644
--- a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
@@ -9,12 +9,11 @@ DEPENDS += " \
python-pbr \
"
-SRCREV = "86635868c1eb3aec0c065c12cb9928c613940f36"
-PV = "1.1.0+git${SRCPV}"
+SRCREV = "13b25ff1fed908cfe7b4e719a97efd7121e3be96"
+PV = "2.8.0+git${SRCPV}"
SRC_URI = "\
- git://github.com/openstack/${BPN}.git;protocol=https \
- file://fix_glanceclient_memory_leak.patch \
+ git://github.com/openstack/${BPN}.git;branch=stable/pike \
file://glance-api-check.sh \
"
@@ -29,13 +28,20 @@ DEPENDS += " \
python-pbr-native \
"
-RDEPENDS_${PN} = "gmp \
+RDEPENDS_${PN} += " \
+ gmp \
+ bash \
+ python-pbr \
+ python-babel \
+ python-prettytable \
+ python-keystoneauth1 \
+ python-requests \
python-warlock \
+ python-six \
+ python-oslo.utils \
+ python-oslo.i18n \
+ python-wrapt \
python-pyopenssl \
- python-prettytable \
- python-setuptools-git \
- python-pbr \
- bash \
"
MONITOR_CHECKS_${PN} += "\