aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git.inc b/meta-openstack/recipes-devtools/python/python-setuptools-git.inc
new file mode 100644
index 00000000..18bc1dc9
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-setuptools-git.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Plugin for setuptools that enables git integration"
+HOMEPAGE = "https://github.com/wichert/setuptools-git"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3775480a712fc46a69647678acb234cb"
+
+SRC_URI[md5sum] = "40b2ef7687a384ea144503c2e5bc67e2"
+SRC_URI[sha256sum] = "ff64136da01aabba76ae88b050e7197918d8b2139ccbf6144e14d472b9c40445"
+
+inherit pypi
+
+# conflicting file prevention
+do_install_append() {
+ rm -f ${D}${libdir}/python*/site-packages/site.py*
+}
+BBCLASSEXTEND = "native"
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb
index 2514017d..03170021 100644
--- a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.2.bb
@@ -1,16 +1,2 @@
-DESCRIPTION = "Plugin for setuptools that enables git integration"
-HOMEPAGE = "https://github.com/wichert/setuptools-git"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3775480a712fc46a69647678acb234cb"
-
-SRC_URI[md5sum] = "40b2ef7687a384ea144503c2e5bc67e2"
-SRC_URI[sha256sum] = "ff64136da01aabba76ae88b050e7197918d8b2139ccbf6144e14d472b9c40445"
-
-inherit setuptools pypi
-
-# conflicting file prevention
-do_install_append() {
- rm -f ${D}${libdir}/python*/site-packages/site.py*
-}
-BBCLASSEXTEND = "native"
+inherit setuptools
+require python-setuptools-git.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb b/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb
new file mode 100644
index 00000000..5dd6804a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-setuptools-git_1.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-setuptools-git.inc