aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-croniter.inc19
-rw-r--r--meta-openstack/recipes-devtools/python/python-croniter_0.3.30.bb21
-rw-r--r--meta-openstack/recipes-devtools/python/python3-croniter_0.3.30.bb2
3 files changed, 22 insertions, 20 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-croniter.inc b/meta-openstack/recipes-devtools/python/python-croniter.inc
new file mode 100644
index 00000000..885aa9e1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-croniter.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "croniter provides iteration for datetime object with cron like format"
+HOMEPAGE = "https://pypi.python.org/pypi/croniter/0.3.4"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=b8ee59850b882cbf623188489ea748e2"
+
+# Archived version so we have to overwrite what the pypi class will derive
+PYPI_SRC_URI = "https://pypi.python.org/packages/source/c/croniter/croniter-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "e4a8987521b144c4c2149d4adde8f55c"
+SRC_URI[sha256sum] = "538adeb3a7f7816c3cdec6db974c441620d764c25ff4ed0146ee7296b8a50590"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-dateutil \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-croniter_0.3.30.bb b/meta-openstack/recipes-devtools/python/python-croniter_0.3.30.bb
index 2859441a..c5cb4140 100644
--- a/meta-openstack/recipes-devtools/python/python-croniter_0.3.30.bb
+++ b/meta-openstack/recipes-devtools/python/python-croniter_0.3.30.bb
@@ -1,21 +1,2 @@
-DESCRIPTION = "croniter provides iteration for datetime object with cron like format"
-HOMEPAGE = "https://pypi.python.org/pypi/croniter/0.3.4"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=b8ee59850b882cbf623188489ea748e2"
-
-# Archived version so we have to overwrite what the pypi class will derive
-PYPI_SRC_URI = "https://pypi.python.org/packages/source/c/croniter/croniter-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "e4a8987521b144c4c2149d4adde8f55c"
-SRC_URI[sha256sum] = "538adeb3a7f7816c3cdec6db974c441620d764c25ff4ed0146ee7296b8a50590"
-
inherit setuptools pypi
-
-DEPENDS += " \
- python-pip \
- "
-
-RDEPENDS_${PN} += " \
- python-dateutil \
- "
+require python-croniter.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-croniter_0.3.30.bb b/meta-openstack/recipes-devtools/python/python3-croniter_0.3.30.bb
new file mode 100644
index 00000000..6ec5a000
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-croniter_0.3.30.bb
@@ -0,0 +1,2 @@
+inherit setuptools3 pypi
+require python-croniter.inc