aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient/fix_keystoneclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient/keystoneclient-fix-test-path-to-example-certificates.patch31
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb40
3 files changed, 18 insertions, 90 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient/fix_keystoneclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-keystoneclient/fix_keystoneclient_memory_leak.patch
deleted file mode 100644
index 05a1d238..00000000
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient/fix_keystoneclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
----
- keystoneclient/openstack/common/apiclient/client.py | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/keystoneclient/openstack/common/apiclient/client.py
-+++ b/keystoneclient/openstack/common/apiclient/client.py
-@@ -90,6 +90,7 @@
- self.user_agent = user_agent or self.user_agent
-
- self.times = [] # [("item", starttime, endtime), ...]
-+ self.times_max_len = 200
- self.timings = timings
-
- # requests within the same session can reuse TCP connections from pool
-@@ -142,6 +143,12 @@
- def reset_timings(self):
- self.times = []
-
-+ def get_timings_max_len(self):
-+ return self.times_max_len
-+
-+ def set_timings_max_len(self, new_len):
-+ self.times_max_len = new_len
-+
- def request(self, method, url, **kwargs):
- """Send an http request with the specified characteristics.
-
-@@ -173,6 +180,9 @@
- if self.timings:
- self.times.append(("%s %s" % (method, url),
- start_time, time.time()))
-+ # remove oldest items until we maintain max length
-+ while len(self.times) > self.times_max_len:
-+ del self.times[0]
- self._http_log_resp(resp)
-
- if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient/keystoneclient-fix-test-path-to-example-certificates.patch b/meta-openstack/recipes-devtools/python/python-keystoneclient/keystoneclient-fix-test-path-to-example-certificates.patch
deleted file mode 100644
index a75e1da2..00000000
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient/keystoneclient-fix-test-path-to-example-certificates.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fae14f85d43da3842b2a065baf0442d61a573598 Mon Sep 17 00:00:00 2001
-From: Keith Holman <Keith.Holman@windriver.com>
-Date: Fri, 13 Jun 2014 17:08:03 -0400
-Subject: [PATCH] keystoneclient: fix test path to example certificates
-
-The tests included with keystoneclient expect them to be ran from the
-source tree. This fix changes base path of the system to where they
-are actually deployed on the system. This fix is required for some
-tests to work properly.
-
-Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
----
- keystoneclient/tests/client_fixtures.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/keystoneclient/tests/client_fixtures.py b/keystoneclient/tests/client_fixtures.py
-index 1743162..6bfcb93 100644
---- a/keystoneclient/tests/client_fixtures.py
-+++ b/keystoneclient/tests/client_fixtures.py
-@@ -25,7 +25,7 @@ from keystoneclient import utils
-
-
- TESTDIR = os.path.dirname(os.path.abspath(__file__))
--ROOTDIR = os.path.normpath(os.path.join(TESTDIR, '..', '..'))
-+ROOTDIR = os.path.normpath(os.path.join(TESTDIR, '..'))
- CERTDIR = os.path.join(ROOTDIR, 'examples', 'pki', 'certs')
- CMSDIR = os.path.join(ROOTDIR, 'examples', 'pki', 'cms')
- KEYDIR = os.path.join(ROOTDIR, 'examples', 'pki', 'private')
---
-1.9.3
-
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index 0b67e40c..e82c5f62 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -7,16 +7,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
SRCNAME = "keystoneclient"
SRC_URI = "\
- git://github.com/openstack/python-keystoneclient.git;branch=master \
- file://fix_keystoneclient_memory_leak.patch \
+ git://github.com/openstack/python-keystoneclient.git;branch=stable/pike \
file://keystone-api-check.sh \
"
-PV = "1.7.1+git${SRCPV}"
-SRCREV = "28138b588224c6b0503620ac2e24bd37dad25370"
+PV = "3.13.0+git${SRCPV}"
+SRCREV = "7ff05baa1fa56f152173651f16fc6fd181291292"
S = "${WORKDIR}/git"
-inherit setuptools monitor rmargparse
+inherit setuptools monitor
FILES_${PN}-doc += "${datadir}/keystoneclient"
@@ -31,28 +30,25 @@ DEPENDS += " \
"
RDEPENDS_${PN} += " \
- python-iso8601 \
- python-prettytable \
- python-requests \
- python-simplejson \
- python-oslo.config \
- python-oslo.serialization \
- python-pbr \
- python-argparse \
- "
-
-PACKAGECONFIG ?= "bash-completion"
-PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
+ bash \
+ python-pbr \
+ python-debtcollector \
+ python-keystoneauth1 \
+ python-oslo.config \
+ python-oslo.i18n \
+ python-oslo.serialization \
+ python-oslo.utils \
+ python-positional \
+ python-requests \
+ python-six \
+ python-stevedore \
+ "
do_install_append() {
- install -d ${D}/${sysconfdir}/bash_completion.d
- install -m 664 ${S}/tools/keystone.bash_completion ${D}/${sysconfdir}/bash_completion.d
-
cp -r ${S}/examples ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}
}
-PACKAGES =+ " ${SRCNAME}-tests ${BPN}-bash-completion"
-FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
+PACKAGES =+ " ${SRCNAME}-tests"
FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
"