aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend b/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
index f131e213..7c28fa17 100644
--- a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
+++ b/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
@@ -3,7 +3,7 @@ PRINC := "${@int(PRINC) + 1}"
SRC_URI += "file://postgresql"
-inherit useradd update-rc.d identity
+inherit useradd update-rc.d identity hosts
do_install_append() {
install -d ${D}${sysconfdir}/${PN}
@@ -26,6 +26,10 @@ pkg_postinst_${PN} () {
sudo -u postgres initdb -D /etc/${PN}/
sleep 2
+ echo "listen_addresses = '*'" >> /etc/${PN}/postgresql.conf
+ echo "host all all ${CONTROLLER_IP}/32 trust" >> /etc/${PN}/pg_hba.conf
+ echo "host all all ${COMPUTE_IP}/32 trust" >> /etc/${PN}/pg_hba.conf
+ sleep 2
/etc/init.d/postgresql start
sleep 5