aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/puppet/puppet_3.7.3.bb')
-rw-r--r--meta-openstack/recipes-support/puppet/puppet_3.7.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb b/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb
new file mode 100644
index 00000000..afd9a237
--- /dev/null
+++ b/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Open source Puppet is a configuration management system"
+HOMEPAGE = "https://puppetlabs.com/puppet/puppet-open-source"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f257790c70561550fd666c6e0044fd89"
+
+SRC_URI = " \
+ https://downloads.puppetlabs.com/puppet/puppet-${PV}.tar.gz \
+ file://add_puppet_gemspec.patch \
+"
+SRC_URI[md5sum] = "cc294da1d51df07bcc7f6cf78bd90ce0"
+SRC_URI[sha256sum] = "4a3bd7ddb51072c3dd898a8de158cde204a2d8fd0b84e8ac806b84c074348637"
+
+inherit ruby
+
+DEPENDS += " \
+ ruby \
+ facter \
+ hiera \
+"
+
+RUBY_INSTALL_GEMS = "puppet-${PV}.gem"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/puppet
+ install -d ${D}${sysconfdir}/puppet/manifests
+ install -d ${D}${sysconfdir}/puppet/modules
+
+ install -m 655 ${S}/conf/auth.conf ${D}${sysconfdir}/puppet/
+ install -m 655 ${S}/conf/fileserver.conf ${D}${sysconfdir}/puppet/
+ install -m 655 ${S}/conf/tagmail.conf ${D}${sysconfdir}/puppet/
+}